Trying to compile PHP5


#1

I was hoping to compile a custom PHP5 in my domain so I could use some third party php modules. I edited my domain into the php5 install script from the wiki, ran it, but did it run to completion? I sure can’t find any php.cgi or .ini to use in my .htaccess.

/usr/bin/python ./generator.py .
/usr/lib/python2.3/xmllib.py:9: DeprecationWarning: The xmllib module is obsolet e. Use xml.sax instead.
warnings.warn(“The xmllib module is obsolete. Use xml.sax instead.”, Deprecat ionWarning)
Killed
make[3]: *** [gen_prog] Killed
make[3]: Leaving directory /home/.edison/ykfpdata/source/libxml2-2.6.26/python' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory/home/.edison/ykfpdata/source/libxml2-2.6.26/python’
[kiki]$ make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/.edison/ykfpdata/source/libxml2-2.6.26’
make: *** [all] Error 2

[kiki]$


#2

I don’t know what happened the first time. I edited out the download and extract parts of the installscript and uncommented the make clean lines in each of the make steps, and it ran fine to competition.

About that time, however, I noticed that DH’s installation of PHP5 has dynamic library support enabled. Now I can use my ChartDirector libraries without my own php.