Trying to change my upload file size limits


#1

I made my size so I can post streams of my podcasts. Unfortunately when I try to upload the podcasts in Wordpress, it says they are too big. The limit is 7MB and my podcasts are from 20MB to 110MB.

I’ve been trying to increase the upload file size for the past two days with no luck.

Can anybody please help me?


#2

Use sXi’s handy script to create a custom PHP.ini
http://sxi.sabrextreme.com/dh-phpini

Use it up increase your post_max_size and upload_max_filesize limits.


#3

Nothing happens. I just extract it to my Desktop. Put it in my folder in Filezilla. Then I right click the file and open my browser and it just asks me what I’d like to open the file with.


#4

OK, i followed these instructions, got the CGI-BIN to install, but don’t see how to change the max file size limit. went into the php.ini file but there’s nothing to change. could you further explain?

thanks!!


#5

I have followed the directions for customizing my PHP 5.3 on the dreamhost wiki at:
http://wiki.dreamhost.com/Custom_PHP.ini
which allowed me to change my php_memory_limit
Can I include commands in my phprc file to increase the upload limit? with something like:
post_max_size 50M
upload_max_filesize 50M

or should I follow the directions below? and I follow the directions below will the resulting php.ini file override the directives in the phprc file?

Thanks for help with this one!


#6

If your application works with PHP 5.3, use that! sXi’s script only works for PHP 5.2.

The syntax you’re using is nearly correct. What you want is:

etc.


#7

hello there,
i had use the “http://sxi.sabrextreme.com/dh-phpini” script because i need to increase my upload limit size from 7M to 999M.
everything works, the new custom php.ini is installed with a new limit of 20M,
but when i edit the php.ini (in the cgi folder) and increasing the upload limit for example to 999M
still is staying on 20M … anybody knows what i am doing wrong ?


#8

sorry guys, the php.ini is updated now successful, it was a delay problem i guess from the server, after many hours. :slight_smile:


#9

Are there any settings elsewhere which may override this and take precedence? I used phprc and set:

post_max_size=90M
upload_max_filesize=90M

When I check phpinfo.php I see the above settings reflected, yet I still cannot upload a 33Meg file. Small files, like a 4.9M file I tried, worked. That kind of seems as if some other size limit is restricting me.

Any ideas?


#10

Has anybody in this thread been able to successfully increase file upload capability beyond 30mb by the various methods described here?


#11

Same problem!!!

anyone had success??


#12

I can’t check on this computer, but I’m pretty sure I set mine to 64 or 128 without any problem. Check out sXi’s script. However, you may want to use another method if your files are that large. scp works well.


#13

From what I’ve read in this thread, sXi’s script is to custom edit php.ini to increase uploaded file size, memory, etc… I use phprc which “seems to” increase the limits according to php.ini when I look at it. But when actually performing a file upload I can’t get past about 30Mb even tho php.ini shows 80Mb.


#14

so how do you know the problem is the script and not the speed/stability of your connection?


#15

I didn’t say it was a script problem. I didn’t use the script. What I am asking is, does anybody know what it in fact might be if I have created a custom php.ini which reflects the custom limit increase, yet actual file transfer doesn’t show it really works…


#16

i was referring to php.ini when i wrote script. how do you know it’s not a problem with your connection?


#17

Just to backtrack a little:
Will max_upload_filesize = XX and other directives work in the phprc file? I am trying to make changes to this file and I see no changes in the frontend – is there usually a waiting period?

Thanks as always…


#18

post_max_size = n upload_max_filesize = n

If you’re running as FastCGI there’ll be a delay of a few minutes or so while the PHP processes die off.


#19

Thanks sXi – it finally went through. I am all set.