Trouble with edit Mambots plugins


#1

After 1-click installation of Joomla, I’ve tried to install a Gallery2 Image Chooser plugin, but found that it doesn’t work.
Source is located here: http://extensions.joomla.org/component/option,com_mtree/task,viewlink/link_id,506/Itemid,35/
When tried to enter the mambot config via Joomla administrative interface, got a “blocked” message and a lock instead of checkbox in the list.

What should I do to enable that plugin? RTFM?


#2

It looks like you have run into one of about 7 confirmed bugs in Joomla! 1.0.11. Most are very minor and easily worked around, and others have fixes available.

The fix for your “locked” mambot configuration involves uploading a new version of the “admin.mambots.php” file into the “/administrator/components/com_mambots” directory of your installation. Discussion of the problem, and the fixed file, can be found in this Joomla! forum post. Note that you have be registered on the forum to see the downloadable file attachement. :wink: .

FYI, you can find the status of other identified bugs in Joomla! 1.0.11 in this Joomla! forum thread :wink: .

–rlparker


#3

Thnx a lot.
Anyway plugin still doesn’t work, but already this is not your problem. :slight_smile:


#4

I’m sorry to hear the component isn’t working. Hopefully, at least getting the updated file will fix the “locked” problem when trying to configure mambots on your back-end. :wink:

Good luck with it!

–rlparker


#5

The hotfix is for the popup message from your browser that says something like “Authorized users only”.

If you’re getting something other than that, check the directory permissions on the directories that hold extensions. Following any of the Joomla “security” tutorials will instruct you to do a chmod on those directories, and the webserver will not be able to upload.

There is functionality in the global config settings of Joomla administration that will modify permissions en masse, but manual is probably the best way.