Trouble viewing my page after uploading



I’m new to this whole website creation thing. I’m creating my wedding website in iWeb, I got my domain from DreamHost, and I am using Fetch as my FTP client.

I’ve followed all the instructions for using Fetch with iWeb, and DreamHost’s instructions as well. But even after I have uploaded all my iWeb files to the root, when I try and preview my site from Fetch, I get this error message:

"Not Found

The requested URL /index.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

When I try to navigate to my page directly, without using Fetch’s Webview, I get this:

“Index of /
Name Last modified Size Description”

I went through all of Fetch’s troubleshooting with on of their service techs, and he thinks it must be a DreamHost issue - specifically that I have uploaded my files to the wrong place, but when I tried to specify an ‘initial path’ as my DreamHost domain (per his suggestion,) I got this error:

"Fetch could not open the folder ""because the FTP server says that the requested item was not a folder or could not be accessed.

If you entered a folder name or URL, check that it is correct. Server responded “ No such file or directory.”

I don’t know anything about what I’m doing and can’t even begin to troubleshoot my problems.

Can anyone who might be familiar with the Fetch client help a poor girl out?



Here’s some information you may not know.

First you need to make sure you are using the right username.
Go to Manage Domains in the DreamHost Web Panel and “Edit” the domain to make sure the username matches what you are using in Fetch, and make note of the web directory.

Web site files need to go in that directory. So you must log in as the user for the domain, make sure the directory exists (which it does if you get a blank “index” page)

You might have a “path” problem. Say your web directory is “/home/betsy/” -

For FTP, web site upload path is / (URL form

For SFTP, upload path would be ~/ or /home/username/ (URL form s

Hope that helps.

:cool: -//-


Thank you for that, I had been just sticking with the default, which was FTP. But just now, when I tried SFTP - both with an initial folder (, and without - I got this error:

"SFTP connection to “” could not be opened because the connection to the SFTP server could not be established or was lost.

Try again, or contact the server administrator to verify that you have the correct hostname, username, password and authentication method, and that the server is running."

That can’t be right, am I making some other mistake?



SFTP will only work if you have it enabled in the Web Panel…you’d have to go to Users and change a setting for the user.

Try logging into first. See if you can upload a file to /domain and see if it appears when browsing to your site. That will at least elimnate any problems on DreamHost computer.

:cool: -//-


Try connecting using your server’s address (as opposed to your domain addy).


You can find the Web Server Name in Panel under the [color=#0000CC]Account Status[/color] dropdown.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


I uploaded a file (called index.html, part of the iWeb set of files) to the web FTP server.

I then navigated to my site independently and got the Index of / list - my file was not listed, is that what you meant?

The list on that page has never reflected anything of what’s in the directory, it’s always blank - let alone actually showing the site.



I tried that too - I’ve tried both ways.

It doesn’t seem to matter what I change, if I use FTP (and specify the initial path as my domain,) I get one error message. If I use SFTP (which I went in and ‘enabled’ but that didn’t change anything) I get a different error message. At no time does any file show up in the root online, or does any page manifest.

But I do really appreciate the help, is there anything else I could try?



I’m on a break right now, I’ll PM you and see if we can check what’s going on.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


In Panel:

[color=#0000CC]Domain > Manage Domains[/color]

Ensure you have Fully Hosted your registered Domain name and applied the correct user :wink:

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


It looks all set to me. Above my domain it says ‘Fully Hosted’ and in users, the username I gave you is the only one there is.



Try the WebFTP approach. It’s preconfigured, so it should get you to the right place. And what’s the URL to your site? It’d be nice to see this emptiness in person.



the URL is my domain -

Even in the WebFTP you have to pick somewhere to upload the files to, and since just putting them in with everything that’s there seems to be the wrong answer, I don’t know where else to put them. The file/folder list I see on WebFTP is exactly the same as the one that shows up in Fetch.



As others have said, you should see a folder as soon as you log into FTP. That is where your stuff belongs. If you don’t see that folder, make one and then put your stuff in it. Setting up hosting for that domain should have created that folder for you. Either you set up hosting differently, or that folder got accidentally deleted.

If you put stuff in that folder and it still doesn’t work, you need to take a closer look at how hosting is set up for that domain.



When I have tried that approach - creating a folder called ‘’ and putting all my iWeb files in it, I just get a homepage called:

And this message:

Not Found

The requested URL / was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

This doesn’t seem right to me. I don’t know how hosting is set up for that domain - my dad did the initial setup and he has numerous sites with DreamHost (which all work just fine) and I’m sure he set it up just the same as he has before.

What should I be looking for in my Panel that would clue me in to something being set up wrong?



Something definitely went skewiff at some point in time, as SFTP failed and FTP showed a ‘blank’ userspace. I’d actually suggest moving the domain to another userspace.

[color=#0000CC]Users > Manage Users[/color]

Click Add A New User.

Type of User Account: - Shell
Shell Type: - /bin/bash
Username: - [Newly_Created_User] <- pick anything
Enhanced security? - Checked

Type in a password and click [color=#0000CC]Add User[/color] at bottom.

[color=#0000CC]Domains > Manage Domains[/color]

Next to click [color=#0000CC]Edit[/color] in the Web Hosting column.

Extra Web Security? - Check
FastCGI Support ? - UNcheck
Ruby on Rails Passenger - UNcheck
FTP user / CGI-runs-as user: - [Newly_Created_User]
Copy domain’s files to new user? - UNcheck
Specify your web directory: - Should be auto-filled as
How do you like the www in your URL? - Both

Click [color=#0000CC]Change Fully Hosted Settings Now[/color]

Wait a few minutes then login with [Newly_Created_User]'s credentials.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


Thank you!!! I created a new user and followed all your instructions, lo and behold - there was a folder already created with my domain in it (and all this time I thought you were putting me on (: )

This seems to have worked!

Thank you all so much for your help!



I am also facing the same problem…

I have uploaded my file on dreamhost server but still showing not found in web browser

How can I fix this issue ?