Trouble getting started with Wordpress


#1

I’ve been reading the wiki for the last few hours and I don’t see any answers to this basic question - it seems the wiki already expects you to know what you’re doing.

I want the wordpress “about” page to be the first page ppl land on when they enter “darwinblog.com” But when I try to install using either the easy mode or the advanced mode it wants me to have a subdomain. I don’t have one of those, and I don’t want one anyway. I don’t want people to have to type “blog.darwinblog.com” or “sql.darwinblog.com” just to get to the front page, to me that makes no sense at all.

How do I put the wordpress files in the root directory of the site?


#2

For the advanced install, do you already have a Fully Hosted Domain set up? If so, then the worst that happens is that it tells you that the directory isn’t empty.

For the Easy Install, you should not already have the domain set up (i.e. Fully Hosted).

-Scott


#3

Ok, let’s put your questions in a slightly different order (that is more consistent with what you are trying to do) :wink:

This depends on how you are installing WordPress. If you are installing WordPress manually, just follow the installation instructions and make sure you place the distributed WordPress file/directories into your “yourdomain.tld” (where “yourdomain” is the name of your domain, and “.tld” is the "top-level domain - .net, .com, .org, etc.) sub-directory of your user space.

If you are using either of the DreamHost “One-click” installers, the same thing applies, but you will not be able to do this if you already have files in that directory (the DH one-click installer requires the “target” directory be empty).

For instance, to install WordPress so that it is shown whenever anyone browses to darwinblog.com, simply specify that, without any subdirectory) as the target for the installer. At the part of the form that asks where to install ("Install to: Please be sure there are no files there now!<place for a subdirectory to be specified if desired), just select the “http://www.darwinblog.com” and ignore the following space where yuo could have defined a subdirectory. Again, note that the directory you choose must be enpty for this to work. :wink:

Assuming yuu have completed the step(s) above properly, and now have a WordPress blog running on http://darwinblog.com, you can configure that instance of WordPress to use the “About”" page (or any other page) as the “home” page for the blog by logging in to the admin section of WordPress and making the appropriate setting changes.

In the current version of WordPress (2.5.1) this is done from the “Settings -> Reading” screen, where the top section under “Reading Settings” shows “Front page displays” and offers radio buttons to make the front page either "Your latest posts " (which is the default) or “A static page (select below)” (with drop-down boxes for existing pages/or a given page of “posts”). Just select “About” from that list for the “static page” and save the form.

–rlparker


#4

Hi Scott,
thanks for your reply.

I’m not sure you mean by a “fully hosted” domain. “Fully hosted”, as opposed to what? I started out by just clicking on “sign up now” on the Dreamhost front page, then answered a few questions and paid my money… $6.95 a month, for a year, IIRC.

The actual error message I’m getting if I try the advanced setup is “Bad Hostname: sub-domain is blank”. But of course it is - as I said in my original post, I don’t want a subdomain.

If I FTP into the account, there are no files or directories there at all.


#5

Hi rlparker,
thanks for your reply.

I’m trying to use the one-click installers, preferably the advanced one, so I can mess with the themes etc later. There are no files in there at the moment - I’ve verified that by just going to www.darwinblog.com in a normal browser, and also by FTPing into it and looking.

I don’t want it to go into either a subdomain or a subdirectory at all…


#6

hat sounds good, so you should be all set to go with the instructions from my earlier post.

Once you have “Added a domain” for “darwinblog.com” (which it appears you have already done, as I can see the “empty” directory), all you have to do is complete the “advanced” one click installer as in my previous post.

Do not be confused with the MySQL “Host” part of the installer - that is unrelated to how anyone browses to your blog, but is needed to provide a connection to the database (which you will also be creating) for WordPress.

I suggest leaving the MySQL host as suggested (mysql.darwinblog.com) unless you have a reason to want to do it differently. Good luck!

–rlparker


#7

thanks guys for helping me get this set up.
I reset it back to “mysql.darwinblog.com” as suggested, and it’s working now :slight_smile:

not at all intuitive, but it worked, so that’s all that matters.

cheers guys :slight_smile: