Transfert SFTP don't actualize the page + cannot send email


#1

New to www.dreamhost (to get the free https) we are on a VPS plan, and i struggle with a created account who manage just a sub.domain.com (we have 5 sub.domain.com for languages purpose)

As a main account i got no problem to upload by SFTP the changes are immediately seen on the website…
But when the account restricted to the sub.domain.com (she) upload by SFTP, FileZilla said OK upload done… But the file is not overwritten !

I have even tried with her account from my computer, same thing it does not overwrite the online file, tried to delete the file, file deleted, But when i upload the file it’s like the server put back the old file!

If someone can explain where i’am going wrong

Second thing we got huge problem with our email we can receive email (when it want to connect :frowning: ) but most of us cannot send email via outlook even myself with evolution (ubuntu).
so i have activated the imap and pop3 on the VPS (even if it was written that useless) and still the same problem… and now it’s few days, for the company it’s quite not good (we pass by webmail to answer)

Any suggestion ?


#2

This is a guess as to what you may have done wrong. New users typically don’t understand the concept of USERS at dreamhost.

Navigate to Manage Domains in the panel, check the “Web Hosting” Column for each of the 5 Sub-domains. What does it say for USER? Is that the user that is being used to upload the files via SFTP?

This help page that may help you understand the relationships between Users, and (sub)domains.

– Regarding mail, mail servers are different servers than webservers or VPS’s. If your unable to send with Outlook I suspect the problem is that you haven’t configured outgoing (SMTP) to use authentication. By default Outlook doesn’t configure the outgoing server to use Authentication however dreamhost requires Authentication.

I don’t know your Outlook version, but in Outlook 2016:
File > Account Settings > Account Settings > (click the dreamhost account- Type:IMAP/SMTP) > Click Change > “More Settings” button > “Outgoing Server” tab > check box for “My outgoing server (SMTP) requires authentication” and put the radio button on “Use same settings as my incoming mail server”.