Trac with dbauth, almost there but: "AssertionError"



I have set-up and SVN through my panel.
I have set-up trac through the panel as well.

I would like to have proper “login” controls on my trac project. For this reason I have installed dbauth and configured it to work with a mysql database that I set-up through my panel as well.

I believe I have completed most of the steps correctly, the mysql database is fine, it has all the fields in it set. It has an admin user as well. It is accessible. The trac.ini file is configured properly so it links to the database etc. I have used trac-admin to give permissions to the user.

I have followed these instructions (partially):

I am getting the following error when I try to login:

[code]Trac detected an internal error:

AssertionError: HDF dataset not available. Check your clearsilver installation[/code]

[code]There was an internal error in Trac. It is recommended that you inform your local Trac administrator and give him all the information he needs to reproduce the issue.

To that end, you could a ticket at this site.

The action that triggered the error was:

GET: /login[/code]

Any ideas? Thanks.[hr]
As far as I understand this is an error related to the dbauth plugin maintained at:

I am really confused… is this a python issue? is this some other problem?

Please help me, I have been trying to get trac running for the last week and it works fine with the default installation through the panel. Even login-hack works with the .htaccess file. But when it comes to make the actual login system work, it is a total torture!!!



I am not sure if clearsilver is installed, or is wrong some how. I suspect that this might be a mysql problem. Cause the auth db that I link to dbAuth is UTF_8_bin, it should be UTF_8. So I will try with a new db which is UTF_8. Maybe the clearsilver module is getting bad data from the UTF_8_bin db and breaks.


After reading about unix environments and per-user settings on the Dream host wiki, I managed to set-up a healthy environment and install clearsilver 10.5.

The command:
python -c “import neo_cgi; print dir(neo_cgi)”

[‘CGI’, ‘CGIFinished’, ‘IgnoreEmptyFormVars’, ‘_C_API’, ‘_C_API_NUM’, ‘doc’, ‘file’, ‘name’, ‘cgiWrap’, ‘exportDate’, ‘htmlEscape’, ‘htmlStrip’, ‘text2html’, ‘update’, ‘urlEscape’, ‘urlUnescape’]

Which is the proof that clearsilver is accessible on the run-time environment, at lease the one in my SSH session. So clearsilver is there.

Now I need to put back my mysql db cause I have removed it. And try the dbAuth plugin once again.


I tried everything… I cannot get rid of this:

I tried all kind of sqlite3, mysql databases, both on files and on servers, they are all fine. They all have the right tables and the right formats and the right values.

And yet I still could not get rid of this error! It is driving me crazy! What is the solution?

Please help!


Just the final on this:
It turns out dbauth has not been maintained for a while. So no one trusts it anymore. Installed AccountManager and the admin functions are working now.