Trac on Dreamhost: I DARE YOU!


#1

I have tried for a week now to get it going. No can do. I have read the wiki entries and the articles by natmaster. His latest one installs no problem (if I downgrade SVN, else I get an SVN configure --with-apache error). But it wont be accessible on the web. Period. The error logs

[Sun Jan 28 07:56:20 2007] [error] [client 24.239.151.1] FastCGI: comm with (dynamic) server “/home/izk/trac.exd-dev.com/index.fcgi” aborted: (first read) idle timeout (60 sec)
[Sun Jan 28 07:56:20 2007] [error] [client 24.239.151.1] FastCGI: incomplete headers (0 bytes) received from server “/home/izk/trac.exd-dev.com/index.fcgi”

No, its not a file permissions issue, checked that.

I have read the posts. There seem to be only questions but no answers. Either there are no solutions or once people solve the issue they never share their results. In either case my conclusion is this:

YOU CAN"T RUN TRAC ON DREAMHOST.

You may think otherwise… so, I DARE YOU TO PROVE IT. Help us out and show to the community how you got past these issues to get trac to run.

Isaac Rivera
Technology Director :: Experience Design Group
America Online :: New York City


#2

I’ll suggest you to send a ticket to DH. somebody has a similiar problem before.

you may want to refer this article http://discussion.dreamhost.com/showthreaded.pl?Cat=&Board=forum_programming&Number=60768&Search=true&Forum=All_Forums&Words=fastcgi&Match=Entire Phrase&Searchpage=2&Limit=25&Old=allposts&Main=60768

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color].


#3

Just FYI, I had this same issue recently after making some minor changes to the PHP.ini file. Which makes no sense… but anyways! I noticed on my server, welchs, that there was some rather high loads, so I reported them in a ticket.
That solved (nice and quickly I might add :wink: ), I recompiled PHP5 WITH perl enabled (so modify the line “–without-perl” to “–with-perl”) and then re-installed eAccelerator. Everything has been working well since Saturday… but I’m still skeptical and I have no idea why the fcgi process failed to load when it was working perfectly fine before. My PHP.ini file is also identical now to the one that failed earlier.

So ya… I have nothing yet significant to report on the issue, until I can discover WHY it dies for seemingly no reason. So far my only suspect is high server loads… but that makes very little sense as to why I was required to recompile PHP5.


#4

Did you see the note in our wiki?

http://wiki.dreamhost.com/index.php/Python_FastCGI

“If your website is being hosted on an Apache2 server (almost all new domains will be that way), contact the DreamHost support team asking us to change the Apache2 memory restriction to be compatible with Python/FastCGI. For some reason it doesn’t work with the setup we have in place. Unfortunately we can’t change the setup due to bad PHP processes eating tons of memory.”

  • Dallas
  • DreamHost Head Honcho/Founder

#5

Now you’ve done it! You woke up Dad. I knew you’d get us in trouble. (just kidding)

Wholly


#6

Hmm… this sounded promissing… thank you for pointing it out dallas. but after they increased the memory on my config, I still get the same error:
<page_quote>
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@trac.exd-dev.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
</page_quote>

The log reads:

[Wed Jan 31 09:20:18 2007] [error] [client 64.236.128.27] FastCGI: comm with (dynamic) server “/home/izk/trac.exd-dev.com/index.fcgi” aborted: (first read) idle timeout (60 sec)
[Wed Jan 31 09:20:18 2007] [error] [client 64.236.128.27] FastCGI: incomplete headers (0 bytes) received from server “/home/izk/trac.exd-dev.com/index.fcgi”

Any other suggestions anyone?

Isaac Rivera
Technology Director :: Experience Design Group
America Online :: New York City


#7

same issue with my moinmoin “wiki” FCGI application running Python. Followed all the steps on the support wiki and wasn’t able to produce a winner default page handler, default.fcgi “Hello World!”

DreamHost Support saved the day and everything works great.

“Very sorry about the delay. I was able to trace the issue back to a
simple mistake in raising the Apache softlimit initially. I have
corrected this and you should not longer be experiencing any problems.
Can you please confirm that it is now working correctly?”

Maybe this will help you?


#8

It is worth checking back with our support team to make sure the memory limit was changed properly. They’re still somewhat new to the process.

We’re working on some other changes that will hopefully alleviate the need for this to be done at all, but at this point it’s not clear if it will work well unfortunately.

The current situation is definitely not ideal. 8-(

  • Dallas
  • DreamHost Head Honcho/Founder

#9

I’m having this exact same problem, glad to find it in the forums. I was going nuts thinking I was just doing something wrong this whole time.

Time to contact support. They’ve saved me in the past, I’m sure they’ll come through again. =)

On a completely unrelated note, I referred my co-worker to dreamhost the other day and when he pointed his browser to the DH home page he saw a guy he knows through his friend’s sister on one of those rotating “livin it up” pictures. He said “hey! i know that guy!” Small world.

Anyway, enough of my rambling. Back to pretending to hate dreamhost because something isn’t working right. >=D

DIE DREAMHOST DIEOMG >=|