Too many redirects


#1

In the web panel, under manage domains, I clicked edit, and then clicked, “Remove WWW: Make http://www.greenhousevcce.org/ redirect to http://greenhousevcce.org/

Now when I go to the site it says “The webpage at http://greenhousevcce.org/ has resulted in too many redirects.” I’ve cleared my cookies and tried to set it back to “Leave it alone: Both http://www.greenhousevcce.org/ and http://greenhousevcce.org/ will work.”

But it’s still giving me the error. Can anyone help?


#2

You probably have something in the .htaccess file that’s trying to insert a “www.” If you can’t see a .htaccess file, make sure your FTP client is set to show hidden files. Edit the .htaccess file and remove anything that references your site with www. in front.

-Scott


#3

Thanks for the reply. I tried to locate the file, but it doesn’t seem to exist. I’m having trouble logging into my FTP site, so I’m going through Dreamhost’s web based FTP. I don’t see an option to show hidden files. Any thoughts?


#4

How did you create this site? It could be that the webserver glitched itself when trying to make the change. Try going back to Domains -> Manage Domains and then Edit. Don’t make any changes, but just click the Submit button to force a refresh. If this doesn’t fix it, then submit a ticket to Support. They can certainly track it down.

-Scott


#5

Thank you for the instructions. It worked for my site.