Too many Redirects for Wordpress blog

wordpress

#1

I have a Wordpress blog I can’t access I get this message in Chrome:

//
The web page at http://brianpauling.net.nz/blog/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.

Here are some suggestions:
Reload this web page later.
Learn more about this problem.
Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.
//

I’ve cleared cookies and the problem remains.

It might be the way I’ve set up the canonicalisation of the URL. I’ve got in manage domains as:

//
Leave it alone: Both http://www.brianpauling.net.nz/ and http://brianpauling.net.nz/ will work.
//

Any ideas?


#2

It’s possible that your browser’s cached an incorrect redirect — I was able to load your site without any issues. Try clearing your browser cache.


#3

I get a Page Not Found (404) in WordPress.


#4

As do I… in both Chrome and FF


#5

I got this. Here’s why, and a workaround. I think it’s a bad bug:
Both the server and Wordpress can apparently interfere with the domain name displayed in your url.

If you create a wordpress page on a site without the “remove www.” turned on (in domain settings) and then turn this option on, your wordpress website disappears and the server gives a “Error 310 (net::ERR_TOO_MANY_REDIRECTS)” error. Workaround: reverse the step above (ie choose “leave it alone” in Dreamhost, rather than remove www".) Unfortunately, it seems then to add www. to the url, which is annoying, ugly, etc. Seems like a bug.


#6

Older sites with this configuration work fine. New sites do not. Dream host fubarred it.

Has anyone filed a bug report? If not I will.


#7

Thanks for that - I just looked at the site again and it seems to be ok, and I had set it back to “leave it alone”, so that is consistent with the points raised above. Have not filed a report, please do, much appreciated!