Tiny Tiny RSS


#1

I am trying to install Tiny Tiny RSS on my domain. I’ve seen several blogs and various forum posts here and elsewhere stating they got it working on DH with no problems. I’m hoping someone here can tell me if there is some unusual setting I’m leaving-out or can otherwise help troubleshoot.

I’ve set-up the database, use SFTP to upload the latest version of TTRSS (1.8) to a folder on my domain. I’ve configured the config.php file, initially using the built-in script (…/install) and also verified the settings manually.

However, after uploading the files and configuring, TTRSS will not let me perform the initial log-in using default credentials (admin/password). If I switch to single-user mode, TTRSS gets stuck in a loop loading about 80% then reloading. I get the same behavior on firefox, chrome, & i.e. and on different computers on different ISPs.

I can access myphpadmin for the database. The data table schema was created by the install script (apparently) fine.

Several times, I’ve removed all files and dropped all tables and attempted to reinstall. In addition to attempting to install the traditional SFTP method, I’ve also tried a GIT-based install of the lastest truck (per recommendations on the TTRSS forum). I even tried installing several older versions. However, I continue to have the exact same results.

In the config.php file, one setting I’m not sure about is the php_executable (path to the PHP Command Line executable.) Default is setting “/usr/bin/php”. I’ve tried various paths, but no luck so far.


#2

I feel so weird, when I set mine up, there wasn’t an install script!

PHP is in /usr/local/bin/php for most of us. You can type ‘which php’ from command line, though.


#3

Thanks! I was actually in the process of trying to do another clean install when I got notification of your reply. Changing the PHP path didn’t resolve the issue. I’ve also tried chmod 777 on the lock directory, which I’m guessing is not a good idea and it didn’t fix the problem anyway. Do you have any other suggestions for config.php settings, or any other ideas?


#4

I just ran through the install myself and the config it came up with was correct.

Check that your config.php ends with ?> and there’s no blank line after it.


#5

My config.php does have the closing “?>”. There was a blank line, so I removed it (and verified the file was in unix format), but that didn’t resolve the issue.

So, the only config.php options you changed were?:
DB_TYPE
DB_HOST
DB_USER
DB_NAME
DB_PASS
DB_PORT
Did you not change the default PHP_EXECUTABLE?

If I PM to you the URL of my reader install, would you be willing to check if you have the same problem logging in?


#6

/usr/local/bin/php points to 5.2 on the server I’m on, tt-rss requires 5.3+

2 things to do:-

make sure the domain is set to use 5.3 or 5.4 in the web panel > manage domains > domain.com (im using 5.4)

edit the line in the config to point to php 5.3 or 5.4 on your server should be:-

/usr/local/php53/bin/php

or

/usr/local/php54/bin/php

the CRON should be something like this on the panel (again 53 or 54, i’d use 54):-

/usr/local/php54/bin/php /home/user/domain.com/ttrssdirectory/update.php --feeds --quiet

here is my CRON setup:-

Finally, clear your browser cache completely, may also be an idea to switch off the mod_pagespeed if enabled in the domain config.


#7

D’oh! Thanks MadBob. I forgot command line uses the older one.


#8

I got it working! The domain was already set for 5.3fastcgi (default) and mod_pagespeed was off. I changed the php_executable in config.php, cleared the browser cache, and… it still didn’t work. So, I tried 5.3cgi, cleared the cache, and … nope

Then I switched to 5.4cgi, updated php_executable, cleared the cache and that did it.

Thank you for the help