Timezones

apps

#1

I’m sure someone else has struck this… the DH servers appear to run US/Western Seaboard time (correct me if I’m wrong here) so my Mambo installation cannot ‘reach’ the timezone here in Australia or for my customers here and in New Zealand. There is a 17-20 hour time difference created by the use of West Coast time on the server -Mambo can handle up to a 12-hr difference, plus or minus. Ideal if server time was GMT/UTC. Is there any command I can drop on my virtual server to correct this back to GMT/UTC? Alternatively, does anyone have a ‘fix’ for Mambo (I’m running 4.6.0) to extend its ability to handle this difference?
TIA :slight_smile:

RS


#2

I haven’t used Mambo, but I know Joomla split off of it, so they must be very similar. There are two seperate offset values in the Joomla locale settings. One is for the users timezone in the form of offset from GMT. The other says “server offset”.

These are stored in the configuration.php file like this:

$mosConfig_offset = '3'; $mosConfig_offset_user = '-4'; They’re not quite right in my case. I think they need to be 2 and -5, but you can’t seem to change serveroffset in the admin. I just messed with it until the popup info window displayed the correct time here: http://benconley.net/images/articleimg/joomlaConfig.gif

While there is no modifier greater than 12, you will be able to get to the right number using the correct combination.

http://benconley.net
http://teamshocker.com


#3

I can’t speak much for “Mambo” (…which means I probably shouldn’t be postig here) but there is an overall “fix” for timezone woes. In your .htaccess file you can slap in a line that reads:SetEnv TZ America/New_York…where you’d change the “America/New_York” to either “Pacific/Aukland” or “Pacific/Chatham” (…dunno specifically where ya are, but you get the idea).

Note that if you’re running this from shell or in crontab, you’ll need to edit your .profile or crontab input file to include a line that reads:export TZ="America/New_York"to properly implement the timezone for stuff at the OS level - the .htaccess setting is purely for the Apache daemon.


#4

Thanks so much! This is one of those niggly wee problems that has been causing me grief, but thanks to you fix it seems to be at least on the way to sorted! I don’t have the option to edit the user offset in the admin, so just dropped the commands straight into the config.php and that seems to have done the trick!

Again thanks :slight_smile: