Textpattern txp:password_protect

apps

#1

I just moved over to DreamHost and my Textpattern site is working fine except for one thing. I have one page on the site that’s password protected using the txp:password_protect tag. It worked fine at my old hosting service, but doesn’t work at DreamHost.

At DreamHost, I’m getting prompted to enter the password (that’s good), but when I type it in the password prompt just comes right back (that’s bad). Yes, I did make sure I’m typing in the right username/password on the form.

Any ideas?


#2

It may be that the textpattern program is using a feature of your old sites PHP that is not available under the PHP settings for DreamHost.
Have a search through the textpattern forum to see if they can suggest a workaround. This page looks like a similar problem to yours and someone more knowledgeable in PHP will explain why it is broken. Something along the lines that your program runs under PHP as an Apache Module but new/changed accounts on DreamHost run PHP as a CGI.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#3

Norm, you hit the nail on the head. I made a post on the textpattern forum, and got a pointer to this thread. Basically this doesn’t work because as a new account holder, PHP runs as a CGI.

That same thread provided the workaround. All I had to do was add AddHandler application/x-httpd-php .php to my .htaccess file.

Thanks!
Phil