TeamSpeak3 on PS with MySql


#1

Ok, so I got myself a shiney new private server so I could use it to run Teamspeak 3. However, I’m having some significant difficulties setting it up.

All the teamspeak files are uploaded properly and permissions set. However, when I try to run the command:

$ ./ts3server_linux_x86 inifile=ts3server.ini

(the command to start the server, with the mysql database info in ts3server.ini) it says:

After reading through the teamspeak forums and noticing that this is a fairly common problem, I realize I have to load the library first. So, I run:

$ ldd libts3_mysql.so 

And then it comes up with this output saying:

Now, as I understand it, libmysqlclient.so.15 is a file that should be on Dreamhost’s servers (one of the techs said it was in /usr/lib/libmysqlclient.so.15 ). Any ideas on how I can get this to work? I tried getting another copy of libmysqlclient.so.15 and sticking it in the same directory as the teamspeak server, but no go.


#2

Ok so I solved the first problem, it was a 64bit/32bit mixup.


#3

Same problem here, I really wish you explained what you did so I could do the same >.>

Just saying, it would be appreciated!

Cole