Symfony2 installation

software development

#1

I tried to install Symfony2 and I still having some problems with it.

I installed PHP 5.3.8 and it’s working, then I uploaded everything using FTP but I’m having this error still:

Fatal error: Class ‘IFZ\TowerOfDimensionsBundle\Repository\SteamRepository’ not found in /home/hagalaz/towerofdimensions.com/app/vendor/doctrine/lib/Doctrine/ORM/EntityManager.php on line 578

The program work perfectly in my local, so, I don’t know what could be.

Also, do anybody knows a way to deploy the projects? I tried Capifony/Capistrano and doesn’t seem to work :frowning:


#2

Offhand, it sounds as though PHP is unable to find some files in your application. Assuming that you’re sure that you’ve uploaded everything, one possible culprit is case sensitivity: the Windows or Mac systems that I suspect you’ve been developing your application on treat capital and lowercase characters identically in file names, but our Linux servers treat the two differently. Check to make sure that you’re referring to files using consistent capitalization throughout. (The file mentioned in the error message, or one of the directories it’s in, is a likely culprit.)