Symfony2 authentication failure (fast_cgi problem)

apps

#1

Hello board,

I am using symfony2 on a test machine and authenticating using http basic fine. When I tried uploading the project on my dreamhost site suddenly authentication does not work any more.

As far as I read there is supposedly a problem with fast_cgi on dreamhost that won’t allow the request headers to be passed to the php script. Is this true? How can this be bypassed?

I’ve read I should add [E=X-HTTP_AUTHORIZATION:%{HTTP:Authorization},QSA,L] on my .htaccess file but this didn’t do the trick, unless I must do something in addition.

Any help would be appreciated!


#2

hint for best help on forums: When quoting a proposed solution as you have, a link to where you got the information will help greatly. It may also help get incomplete information updated for other users.


#3

Opinion: If you don’t know the answer, providing hints to where I got some help won’t do the trick. /Opinion

But if you NEED to know:

http://agilewebdevelopment.com/plugins/simple_http_auth is the initial link and I found also
http://planetozh.com/blog/2009/04/http-authentication-on-php-as-cgi-like-dreamhost/

which both suggest that it should work, albeit the token is stored in different variable (in the second case REMOTE_USER) but I still wasn’t able to make it work with symfony2.


#4

wait, you’re having trouble with basic authentication, not symfony? or symfony’s use of basic authentication? if the former, have you set up the .htpasswd file and changed your pointer to match its new location? i don’t use symfony, but internally it might be looking for that file with a path that matches your local computer but not the path on DH

FWIW, i don’t think there should be any problem reading the headers from the script. i run all of my php projects on fastcgi and they all get info from headers[hr]
opinion: oh, sorry, i just looked at the links you posted and now have a better conceptualisation of your problem. the above probably won’t work. /opinion