Symfony2 and mbstring.func_overload

software development

#1

Hi All,

I’m trying to install Symfony2 on a DH shared server. I gave up on using composer to set up the project due to it being a memory hog and getting killed each time I tried. Instead, I set it up on my local dev and FTPd everything over. That got me to the point that I could run the config check in the browser and I got this as a major problem:

Set “mbstring.func_overload” to 0 in php.ini* to disable function overloading by the mbstring extension.

I went to work setting up my own custom php settings with phprc and php.ini files in my /home/[user]/.php/5.4 directory and put the following directive in both of them just for good measure:

mbstring.func_overload = “0”

When I pull up a phpinfo page in the browser it shows that mbstring.func_overload is indeed set to 0, but the Symfony config check is still complaining about it and it’s keeping me from finishing setting things up.

I’m hoping somebody else here has had this problem and knows a solution, or one of the DH experts can tell me if I’m just flat out doing something wrong.

Thanks in advance
-phpbutcher


#2

Hello! Just solved this issue by setting the ‘mbstring.func_overload’ value to ‘1’, however I really don’t know why SF2 says that it must be disabled (it won’t work that way). When I set it to enabled the config page switched green and everything works well.