Symbolic link not allowed or link target not accessible


#1

I’m running a photo webapp on my site, and I symlink the main “album” subdir in the webapp to store all the photos themselves under a different dreamhost username. (I have a lot of photos and I don’t want this large amount of data to interfere with backups of my main account.)

This setup has worked fine for several years. Recently it stopped working - sometime within the past few months, I’m not sure exactly when. Could have been a change by dreamhost or just as easily a software upgrade I installed. I’m trying to troubleshoot but I’m stumped at the moment.

The PHP webapp still works perfectly – it accesses the original files through the symlink and automatically creates thumbnails and low-res versions for general use. The only part that’s broke is when I click the link to download the full-size original file – the link just points directly to the photo filename. Whenever I click that link, I don’t get the photo, and this error shows up in my error.log:

“Symbolic link not allowed or link target not accessible”

I’ve tried explicitly inserting “Options FollowSymLinks” and “Options +FollowSymLinks” at various different .htaccess files, but this doesn’t seem to fix it. Anybody have any other ideas what might get my photo site working again?


#2

Same here!


#3

It seems that it was fixed.
In my case I also did ‘chmod 751’ on the destination directory