Switching from mod_php 5.2.x to php 5.3.xFast CGI breaks my WP blog

wordpress

#1

I tried changing my domain’s php mode to 5.3.xFastCGI since that’s what’s recommended in the wikis to reduce memory usage. Except now I get an Internal Server Error and can’t even log in to the admin panel on Wordpress. I changed back to mod_php 5.2.x and my permissions seem all screwed up. I can’t install plugins or even upload photos without changing the permissions to 777. I still haven’t managed to get either WP Super Cache or W3 Total Cache to install properly. Though I do already have Xcache active, so do I need a cache plugin?

Anybody know why 5.3 won’t work for me? (I recently upgraded to a VPS from shared hosting if that makes any difference at all.)

Has changing back to mod_php screwed something else up now too? Should I delete the new .php folder that was created when I tried 5.3?

Any ideas? I’m lost with PHP. :frowning:


#2

Avoid using mod_php. It’s fundamentally really weird, from a permissions perspective.

If you need to switch back to PHP 5.2, use it in FastCGI or CGI mode.


#3

It seems to work ok on PHP 5.2 FastCGI, but when I disable mod_php on the server, I get the Internal Server Error again.
[hr]
PHP 5.3 FastCGI with mod_php disabled seems to be working now! Omg did I just fix a problem on my own?? Go me!

All I did was delete php_flag display_errors off and php_flag log_errors on in the .htaccess file.