Svn?


#1

Has anyone looked at using/installing SVN (subversion) within their account?

I see we have CVS, however a large number of projects (such as wordpress, etc) have moved to a subversion repo, due to SVN being somewhat more secure over CVS.


#2

There’s some information on how to do this at the wiki. I haven’t tried installing it myself though.


#3

Like all other stuff like this, vote on the Suggestions section of the Web Panel:

https://panel.dreamhost.com/index.cgi?tree=home.sugg&

We honestly do work on popular suggestions first. And svn’s on the list of stuff to do soonerish, for sure!

nate.


#4

Cool - It (SVN) has been in the suggestion list in one form or another for a year or so… Hopefully it’ll make the cut at some point.

The wiki article was usefull as well - svn runs okay following that. :slight_smile:


#5

I just noticed that we get 40 points now instead of 20. Nice! :slight_smile:


#6

That’s great to hear.

Now, does that mean we’d get SVN supported with WebDAV? I’ve put up a suggestion for mod_dav_svn, which is extremely handy for accessing the repository (most people can get to :80) and for authentication (.htaccess instead of creating system users…)

Is there a way of seeing how many have voted for a certain suggestion? Because that’s one feature in the SVN-family that I strongly believe should be implemented.

Regards,
– tic


#7

mod_dav_svn is only for Apache 2 and we are using Apache 1 as our main http server, and will be for awhile yet.

That doesn’t mean we won’t implement SVN with WebDAV, but it does make the job a little more complicated for us.

We may end up hosting them on a separate machine with a separate subdomain (like svn.mydomain.com) but it’s not clear if that will provide all of the functionality everyone wants. If anyone has any thoughts on that, send them my way.

  • Dallas
  • DreamHost Head Honcho/Founder

#8

Travis Bradshaw has written a short but instructive tutorial for installing SVN on your dreamhost account, in your home directory. He uses version 1.1.3, but it still works with newer versions.

I’m all for DH supporting SVN eventually., as well… :smiley:


#9

Here’s the link for Travis Bradshaw’s writeup:
http://www.tbradshaw.net/archives/2005/03/02/subversion-on-dreamhost/

(I figured I’d save the rest of you the trouble of googling it…)


#10

No, wait – it seems like Dreamhost has installed Subversion on the shared servers after the OS upgrade. Good thing, too, since apparently there’ve been problems with people’s private installations.

Hopefully someone (with more experience than I have) will update the Wiki page with new instructions on setting up a repository.

In the meantime, I wouldn’t recommend trying a Subversion installation in a shared account.


#11

Okay, I’m replying to myself. I figured out setting up a repository, installing TortoiseSVN, and connecting. Believe it or not, with very few snags everything’s working fine! I added basic instructions to the svn wiki page. http://wiki.dreamhost.com/index.php/Subversion

The only remaining issue is that authentication isn’t being cached, so I get prompted repeatedly for my password. From what I can tell, saving passwords is enabled by default in Subversion config, and I tried setting it to yes in my personal config file (in ~/.subversion/config), but no luck.

Anyone? I’ve also reached the stage where I probably ought to contact support… I’m not even sure if they’re supporting this yet. (Yes, I noted this on the wiki page).


#12

You are presumably using SVN+SSH to access your repository with with TortoiseSVN. In which case, the password you’re being prompted for will be the SSH password, which Subversion won’t save.

http://tortoisesvn.berlios.de/?q=node/5 guides you through setting up a public key authentication which will avoid the repeated password prompts.


#13

Thanks! That didn’t quite work – I ended up generating an RSA (instead of DSA) key, but it was a great help.


#14

I’ve just tried this as I would very much like to set up an online repository.

I can set up a repository no problem with “svnadmin create /path/to/repo”

However, when I try and check out the repository with:

svn co file:///path/to/repo

I get the following errors:

svn: Unable to open an ra_local session to URL
svn: Unable to open repository 'file:///home/woodan/svn/aslib’
svn: Error opening db lockfile
svn: Can’t get shared lock on file ‘/home/woodan/svn/aslib/locks/db.lock’: No locks available

I use subversion on my local machine but I’m not expert with it so I have no idea what this means or how to fix it. Does anyone here have any suggestions?


#15

There’s another thread talking about this locking issue.