SVN problem


Hi !
I have an account on dreamhost. I logged in, have been directioned to my home directory. I have, and I’ve set up a repository in the svn directory from my home directory. All ok. Next thing I want to do is to check out on my local machine a copy of what is in the repository (like nothing right now)

when trying to check out from I get this error:

svn: PROPFIND request failed on '/'
svn: PROPFIND of ‘/’: 405 Method Not Allowed (

Please give me some ideas of what to do in order ot be able to check out.
Thank you !
Cimpu Emanuel, student



Normal address is - (need that /svn/)
I think you have to edit svn-access.conf to gain the ability for access using a direct subdomain address.

Try creating a /svn directory in and copy/move your files to it and test browse [repository].
If that works then you could try mirror or redirect your subdomain to that folder.


I’m not sure that’s correct.

I just created a new subdomain:

I then created a new project “tutorials”. Logging in I can see, in my home directory, a directory named svn and it has the information about the tutorials project in it. I can also see the website that appears to be empty.

In my browser I can navigate to and I can see the project name (with no contents, of course.)

In MonoDevelop, when I try to publish the project I get the following message:

MKCOL of ‘/tutorials/!svn/wrk/00471e30-dccf-4d24-96a7-9c9f63e1644c/GTKGladeTutorial’: 405 Method Not Allowed (

Now, this was all set up with the tools in the panel, nothing at all done manually.


It worked 6 months ago :wink:

Did you have a question?

Maximum Cash Discount on any plan with MAXCASH


Well, sure - why isn’t it working?

I wasn’t trying to do this 6 months ago, so it’s inconsequential to me whether or not it worked back then.

I get essentially the same information whether I’m using the MonoDevelop interface or the svn command line client (the 405 part, not the bit from MD that includes a GUID.)

I can set up a local svn server on my box and access it from inside my network at home, so I know the tools work. It could very well be some sort of interaction between my system and DH and this works well for other people. In fact, I suspect it either works well for most people or no one is using svn on DH because this is essentially the only thread talking about this.