Svn killed by signal 15



Is anyone else having problems with svn dying with signal 15? I’m connecting to a repository over svn+ssh. Checkins succeed with a kill after the task is done. Likewise for updates. I ignored it as best I could until last night when a checkout failed.

I thought it might be a version difference so I updated svn on the repository server. The problem didn’t go away so I compiled a fresh svn on jezebel. This fixed my issue and I was able to checkout.

Has anyone else run into this and found a cleaner fix? I can post more information after jezebel comes up if necessary.


Yes, i’m having exact same problems when I run this command (for capistrano rails pull).

dh-server$ svn export svn ssh://me@homebox/path/to/project

Killed by signal 15.

They claimed upgrading to their overpriced PS service would fix this, but it hasn’t. I don’t recommend upgrading if that is what they tell you – it won’t solve this issue.

I’ve tried the same command from other remote servers to my box @ home, and it works fine…I believe they are killing svn ssh commands, just a matter of finding the right person who can fix it.


Work around:

use :deploy_via, :copy