SVN Errors


#1

I created an SVN repository using these instructions:

It said everything was created successfully.

Now when I go to import a directory like this (note that I am replacing mysite.com with my actual site):
svn import MySource http://svn.mysite.com/myproject -m “Initial import” --username paul

I get an error:
svn: E175002: Unable to connect to a repository at URL 'http://svn.mysite.com/myproject
svn: E175002: Server sent unexpected return value (500 Internal Server Error) in response to OPTIONS request for ‘http://svn.mysite.com/myproject

What is wrong?


#2

Additional info: There is nothing in my /home/user/logs/mysite.com or /home/user/logs/svn.mysite.com


#3

I’m having this same exact problem. I initially tried from NetBeans but then tried the command line and received the same message.


#4

I’m getting and HTTP 500 error as well. I’ve tried both silksvn and tortoisesvn and gotten a 500 error with both.

Update and checkout seem to work fine, but commit always errors.

I don’t know if the issue is with the version of subversion on dreamhost or what.

I’ve been using this repository for a while too. It had been sitting unused for several and when I went back to commit some new stuff this happened.


#5

BUMP

I’m having the same issues, too. Has there been an update for this?


#6

Come on guys, why didn’t anyone who already resolved this issue post the solution?

Okay, here it goes:

svn ls http://svn.example.com/repository

It will ask for your credentials:

Authentication realm: http://svn.example.com:80 Repository Name
Username: user
Password for ‘user’:

NOW HERE IS THE TRICK:


ATTENTION! Your password for authentication realm:

http://svn.example.com:80 Repository Name

can only be stored to disk unencrypted! You are advised to configure
your system so that Subversion can store passwords encrypted, if
possible. See the documentation for details.

You can avoid future appearances of this warning by setting the value
of the ‘store-plaintext-passwords’ option to either ‘yes’ or ‘no’ in
’/home/youruser/.subversion/servers’.

Store password unencrypted (yes/no)?

TYPE: YES

and that’s it, bye bye Error 500!


#7

ok. that would answer the question ( even though I am not sure I would agree with apache to throw 500 in this case).
but in my company we are getting the same response in jenkins build server. but the strange thing is that for most of the builds there is no such problem and out of blue some builds are failed for this reason. if build engineer runs on the same build manually (mvn ) it will be just fine. so, it doesn’t look to me as it is svn response on credentials not to be saved locally.

I am starting suspecting that this is timestamp issue

thank you,