SVN commands via Shell not working


#1

I’ve used Subversion on other hosts before, but I’m new to how it works on Dreamhost, and currently I’m having issues with what seem to be pretty routine commands.

I’ve installed svn via the web panel at svn.domain.com with the intention of using it to manage the files I have at domain.com

Everything seemed to go smoothly, and I can access my repository at http://svn.domain.com/repo/

To initially get some files into my repo, I SSH’d into my account via the shell and ran the standard import command:

svn import domain.com/folder/ file:///home/{USER}/svn/repo/trunk/ -m "first import"NOTE: “domain.com” is the web root folder for the domain i want to manage with SVN.

The import worked fine, and the files were then visible via the web interface as well. But then I tried adding additional files to the repo via the svn add command, and that’s where i started running into problems:

svn add somefile.php file:///home/{USER}/svn/repo/trunk/gives this error:

svn: '.' is not a working copy svn: Can't open file '.svn/entries': No such file or directoryI get the same error for every damn SVN command I try to run, other than svn import. Anything from svn list to svn status fails when I execute it from the command line.

Any insight into what the heck is going on here would be much appreciated. Thanks!


#2

Once you import into your repo you then need to check it out so that it is a working copy.

So you’d want to do something like:

svn co http://svn.domain.com/repo/

Hope that helps,
LBO