Support for PHP 5.3


#1

Hi,

I’m considering Dreamhost to move a client’s site here after reading positive reviews.

I have a very specific requirement though:

Need support for PHP 5.3… this is a WP site that effectively broke when my client’s current host upgraded the server (and all their servers for that matter) to PHP 5.4, and the client doesn’t have the budget to have their site revamped/upgraded to have it work on PHP 5.4 (issues with the theme - it’s an oldish theme, 3 years old).

I need to know if:

a) there’s an option to pick the version of PHP when setting up an account OR there’s an option to make this choice once the account has been created

b) how long will Dreamhost support PHP 5.3 (to buy my client some time)

c) will Dreamhost forcibly upgrade servers to PHP 5.4

Thanks!!!


#2

You can choose from versions 5.2, 5.3 and 5.4 currently.

Even with 5.2 being basically dead they don’t force or automate an upgrade on accounts, instead they have a message recommending that you upgrade when you log in to the account’s Panel if it detects any of your domains are using the outdated version.


#3

Only Dreamhost can answer (b). My guess is that you’ve probably got a good 12 months, potentially longer
PHP has moved onto 5.5.x – and based on the past, DH will only incorporate PHP 5.5 once 5.6 releases.

As sXi states (a) and © meet your client’s needs. But your client should look at revamping their theme in the meantime.


#4

We aren’t going to remove PHP 5.3 (or 5.2, for that matter) before we’re forced to do so. The PHP development team has pledged to continue providing security updates for PHP 5.3 until at least July 2014. After that point, though, when a critical security issue arises in PHP 5.3, we may have to discontinue our support for it and start moving customers to 5.4.


#5

And a WordPress theme that hasn’t been updated in 3 years is worrisome; it’s asking for trouble, both from hackers and incompatibility with the WordPress core.


#6

Depends greatly on the theme. The default theme (the old one, Kubric) still works. It’s not insecure. Ugly, but not insecure :slight_smile: