Sugar CRM installation ZIP support in PHP

apps

#1

Hello,

I was trying to install Sugar CRM version 6.4.4 and during the initial checks I get an error because the ZIP support for PHP is missing.

[quote] ZIP Handling Module ZIP support not found: SugarCRM needs ZIP support in order to process compressed files.
Location of your PHP configuration file (php.ini):
/etc/php5/cgi/php.ini[/quote]

Is there any way to workaround this issue and continue the installation of sugarCRM without zip support, if it is not necessary?

Otherwise, any recommendation to install the ZIP support? Normally I can’t modify the php.ini file since I’m not in a VPS/dedicated machine.

Thanks.

Jordi P.
http://www.rourevell.com
http://www.reservango.com


#2

Here is a quick workaround that I found. You’ll still need to get zip support if you want full functionality though.


#3

While your workaround will allow the install to complete, you still won’t have zip support doing that. There are is an easy way to get zip support with PHP on DreamHost.

Just use the “Edit” link under the “Web Hosting” column for the domain on the “Manage Domains” screen of the panel and configure the site to use our installed PHP 5.3.x version, which has zip support included in the compilation.

You could also compile your own PHP for use with your domain, but the above method is much easier.


#4

Hello,

I was struggling to compile my own version of PHP and then I realized I was using the dreamhost’s 5.2 php version.

I did as you explained and worked smoothly.

Thanks,

Jordi P.
http://www.rourevell.com
http://www.reservango.com


#5

Was having this same issue, and this worked great! Thanks for the post.