Sudo denied for VPS admin user


#1

Hi, I’m using a Dreamhost VPS. I set up an admin user using the dreamhost panel to upload some files to the /user/local directory using SSH.

I can log in fine as this admin user, however when I try to use the sudo command I’m told I have the wrong password. I’ve done it a few dozen times so it’s not a typo issue. I have been trying to use the admin user’s password (not root, which I don’t have).

[code]$ sudo scp -r files adminuser@myserver.com:/usr/local/

WARNING: Improper use of the sudo command could lead to data loss or the deletion of important system files. Please double-check your typing when using sudo. Type “man sudo” for more information.

To proceed, enter your password, or type Ctrl-C to abort.

Password******
Sorry, try again.
Password******
Sorry, try again.
Password******
Sorry, try again.
sudo: 3 incorrect password attempts[/code]

The dreamhost wiki says VPS users should have sudo access. I assume they meant automatically for “admin users” set up through the dreamhost panel. Did I miss something?

Thank you.


#2

You are still a limited use on VPS. I doubt you can install packages by yourself :frowning:


#3

did you see this quote on the ‘manage admin user’ page of the panel?

"To make changes to a part of your private server that is managed by the Panel, you must turn off management (you can only do this if you’ve already created an admin user) for that part of the server. Otherwise, your changes may be overwritten by the Panel as it generates configuration files for your server. "

I don’t have a VPS myself so I’m not sure if it helps or not…


#4

Thanks for the replies. In this case, it seems that the problem was in trying to upload directly to a directory that required sudo access.

To get around it, I uploaded the files to a part of the VPS that I did have open access to, then used “sudo cp” to the /usr/local/ directory.

Sudo wouldn’t work unless I was already ssh logged into the server, so I couldn’t use it to copy from my own machine to the server. There may be a better workaround than this, but that got the job done.

Thanks for taking the time to offer suggestions.