Suddenly the website has become slow


#1

Hi

I have just 4-5 pages, mainly text, on my website.

I have made no change to my website in the last 2-3 weeks. But it has suddenly become very slow. It takes more than 50 seconds to load according to pingdom!

Also, when I tried activating Jetpack on my wordpress dashboard, I got this message:

“Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.
Operation timed out after 15001 milliseconds with 0 bytes received”

Does anyone know what this might be about?

Thank you!


#2

Without a site URL so we can run it through a speed test, it’s hard to provide any specific advice. Have you tried looking through your server logs?

Is your WordPress install up to date? When I googled this, most of the threads I found were at least two years old.


#3

Hi

Thanks for your reply. I am such a newbie, I don’t even know what a server log is! I have the latest version of wordpress since I setup my website less than 2 months back. Fortunately, I won’t have to look into the details hopefully.

I roped in the dreamhost support team, and they are on it. Seems like it might be a problem with one of the plugins I installed.

Thanks a ton…


#4

That doesn’t In fact mean that you have the latest. In this case there has not been a non-beta release major or minor in that time frame, but I would call that rare https://wordpress.org/news/category/releases/

You got lucky, dreamhost support usually won’t help at that level. FWIW tho it’s almost always a plugin or theme. The first steps to troubleshoot a WP issue should always be disable plugins and set the theme back to twenty-fourteen (or whatever the default). Then start putting things back until the problem returns.

Plugin “A” mght be a fine plugin on its own, but mixed with plugin “Z” there mght be an incompatibity.


#5

Hi

Thank you for that input. I didn’t know that. I will keep it in mind for the future as well.

On disabling plugins, well, it turns out, the Dreamhost support person, didn’t just disable my plugins, they actually deleted them all, including my backup plugin. And now they are not responding to my emails.

Either way, even with no plugins and no images, and just the genesis framework theme, my website is still taking 25-60 seconds. I do have a linked Cloudfare account. The url is www.fedwinteg.com

Would really appreciate if you have any inputs on how to fix this.

Thank you so much!


#6

Next steps are turn off cloudflare and test, and set the theme back to the default Wordpress theme and test.

What dreamhost service are you using? Shared hosting? VPS? Dreampress? Dedicated? Dreamcompute?