Suddenly get PHP Startup Error

vps

#1

I haven’t done anything on my VPS but suddenly my php log (php_errors_72.log) is filled with

PHP Warning: PHP Startup: Unable to load dynamic library ‘hash.so’ (tried: /usr/local/php72/lib/php/extensions/no-debug-non-zts-2017
0718/hash.so (/usr/local/php72/lib/php/extensions/no-debug-non-zts-20170718/hash.so: cannot open shared object file: No such file or directory), /usr/local/php72/lib/php/extensions/no-debug-non-zts-20170718/hash.so.so (/usr/local/php72/lib/php/extensions/no-debug-non-zts-20170718/hash.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

From what I’ve read, Hash is part of PHP these days so I am not sure where this is coming from. My websites seems to be working OK – but I don’t think I use any hash functions (no passwords stored, etc)

The same VPS has a few websites still running PHP 5 (I know, I know) and those don’t seem to generate any errors, just the PHP 7.2 ones.

Any ideas? Or should I open a ticket with Dreamhost?

Thanks in advance.


#2

I have been having the same issue for the last three days with a php cron script I run every night. From running php -v from the command line, it would appear that a new build of php 7.2 (7.2.24) was installed on Nov. 14. I did open a ticket to have the problem fixed, but I have not heard back from anyone yet. Another option is to switch to php 7.3, which does not give the warning.
Eisso


#3

Glad to hear I’m not alone :slight_smile: I went ahead and opened a ticket yesterday as well. Haven’t heard anything but didn’t expect to on the weekend.

I went the other way: I downgraded all but one website to 7.1 – I left one so they don’t say “We don’t see any problem” :slight_smile:


#4

I second that. Getting the same error.


#5

Got a message back from Support that there was a problem and it is now fixed.