Subversion working?

software development

#1

I’m trying to use the new DreamHost provided subversion but can’t get it working. At best I end up with:

[karnov]$ svnadmin load svn/myrepos < reposdump.txt
svn: No such revision 0

If I try to access the repository using http: (the reason I want to use the built-in DH version) I get the same thing:

<D:error> <C:error/> <m:human-readable errcode="160006">No such revision 0 </m:human-readable> </D:error> If I try to ‘relocate’ my client to point to this repository I get:

PROPFIND request failed on '/repos' PROPFIND of '/repos': 500 Internal Server Error (http://svn.mydomain.com) Anybody have any luck with this yet?

Thanks,
Tom

-Tom Wilcoxen
convergent arts


#2

Just guessing - because I’m an idiot - but does the repository need to exist before you can load it?

I’ve been able to create and attach to a repository using the default subversion.


#3

By DreamHost supplied, I’m talking about the one you can now set up through the control panel - is that what you’ve used? I’d like to use that as it appears to support http access and so could host a trac front end.

Anyhow, yeah, I’ve created a repository. When you add the repository in the panel it’s quite unclear if it is going to create the repo or not, but when I log on in ssh I can’t see it. From the text on the panel I get the impression it would create a repository. Maybe it’s created, but under a different user name.

Now when I try to do a svnadmin load I also get the ‘no such revision 0’ message. Weird.

I wonder if all the servers are enabled. This is on karnov, fwiw.

Thanks,
-Tom

-Tom Wilcoxen
convergent arts


#4

Yes, I’m on mariposa so we might be looking at a configuration issue. I swear that I set it up though my panel and then was able to webav right to it. (note, I did not try to load a repository to it). Although it might have done the exact same thing yours did.

Like you, I’d like to put a trac or collaboa front end on it. You can see the results of my pain elsewhere.

Hopefully the 60 minutes of CPU time per day is averaged over the month…


#5

dreamhost’s svn thing is not working properly. when you create a new svn repos via the web panel, have a look at the processes runnign (ps x). you will see that the svnadmin create process hangs forever, and forever, and forever…

kill it, remove the repos, create it on your own machine, then upload the repos. do this until DH fixes this issue!


#6

Ok, thanks guys. Nice to know I’m not losing my mind.

-Tom

-Tom Wilcoxen
convergent arts


#7

They have fixed the problem with subversion. (at least on my server, karnov). It was an issue with randomness (http://subversion.tigris.org/faq.html#freebsd-hang ) And now it works correctly. I got a reply back from them about it.

I had to delete all my files in ~/svn/ and then re-create the repositories. Everything worked fine after that.

Cotton


#8

Yay, thanks cotton, works great.

I’d been wondering if the control panel was supposed to create the repository, and it does. I deleted my old stuff from the shell and deleted the repository from within the control panel. Then I re-created it from the control panel and it worked great.

-Tom Wilcoxen
convergent arts