Subversion help


#1

Hi,

I created a new subdomain for subversion and installed subversion into the subdomain, leaving the directory name blank.

When the installation was done, I see a directory “svn” under the user’s home directory, and the subdomain completely empty. The svn project was under the svn directory.

How do I expose the repository over the Internet?

Regards,
Vinod.


#2

I’m having the same issue except I didn’t do it into a subdirectory, just a normal subfolder.


#3

Tried using a sub-directory in the domain too… no luck :frowning:


#4

It would appear to be working, now.
I re-read the e-mail and it mentioned moving my site to a subversion enabled server.

Create a repository.
Wait a day.
Try accessing it.


#5

Still not working for me :frowning:

Can you explain how you are accessing it pls?


#6

Seems it requires to use svn+ssh://yourhost.blah/home/your_user_name/svn/your_project_id to access the svn service, and http interface (shown in DH’s subversion panel) doesn’t work? Also, the username and password settings doesn’t seem to work with svn+ssh protocol either. Perhaps I have missed something?


#7

Hi, I’m in the same boat as you. I can’t seem to get the username and password settings to work. Can anyone shed some light on this?

svn+ssh://yourhost.blah/home/your_user_name/svn/your_project_id is the only thing that works for me too. I tried to map a subdomain to it (ie. <svn.yourhost.blah> --> </home/your_user_name/svn/your_project_id>). It seems to point to the directory when i type <svn.yourhost.blah> in my browser but when i try to access using tortoiseSVN, I can only use <svn.yourhost.blah/home/your_user_name/svn/your_project_id> not as big a deal as the password thing but still a pain. Does anybody know how to make this work? TIA.


#8

OK Guys, success at last. First things first…

The svn+ssh method is incorrect for “proper” svn access - the kind that we expect. This is in effect creating a ssh tunnel so that the svn client can access the svn repository directly. This will NOT work for the svn users that you would have defined on your web panel. Since it is using the ssh protocol, it requires you to use your ssh userid and password. In other words, it will only work for one user - your ssh user.

The machine on which the repo was hosted for me - 208.97.133.95, didn’t have a http daemon running yesterday. Maybe there was some problem with the system. Weirdly enough, the other machine on which I had tried earlier - ?.?.?.91 also didnt have the http daemon running.

But now, everything seems to be fine. I can access my svn repo over the http protocol, using the svn userid’s and passwords!!

Seems like it was nothing but an outage, so you guys should check it out again.

Regards,
Vinod.


#9

Thanks Vinod, two birds with one stone… Solved both my problems.

*oops spoke too soon. Still doesn’t seem to work with svn.myhost.com …when I put the link in my browser, i get a directory listing instead of the expected login prompt. help is appreciated…


#10

Does it show this at the bottom of the directory listing -

“Powered by Subversion version 1.1.4 (r13838).” ?

If it doesn’t, it would mean that the svn mod is not active on the server. Do make sure that your domain name is getting resolved to the ip address of the server that has subversion, otherwise this will not work!

I’ve updated the wiki as well

http://wiki.dreamhost.com/index.php/Subversion

Regards,
Vinod.


#11

worked for a bit. doesn’t work anymore here… i think it’s an http daemon problem. on the client side i get PROPFIND request failures. the IP? 208.97.134.91. but when i ssh to that, i end up on my usual machine (grand.dreamhost.com) … so it seems like my svn domain is not actually being served from a svn-enabled server. argh!


#12

I think it is usual that your SVN domain will be hosted by the same server as all your other domains.

Dreamhost run multiple Apache servers on each shared server and distribute the hosted domains across them. Up until now, these have all been Apache 1.3 servers. In order to support SVN, Apache 2 is required. It looks like Dreamhost have added an additional Apache 2 server on each machine with a new IP address. Any domains used for Subversion will be moved to this Apache server.

208.97.134.91 doesn’t seem to be responding to http requests at all at the moment. You should report it using the system status/contact page in the panel.


#13

208.97.133.95 is dead as well, though the downtime check utility on the panel says its working! God knows whats going on!

Last time, I had to wait around 48 hrs for a support reply.


#14

weird… just clicked on edit repository and submitted without any changes.

everything working fine again now :-/