Subversion commit return MKACTIVITY error


#1

I’ve got a recently set up Subversion account on the dreamhost provider (this was one of the reasons for me chosing the provider). I created the account using the panel, then uploaded a dump file from my local repository and loaded that into the site. It shows up fine in the HTTP view and can be checked out without a problem.

The problem I’m getting occurs when I try to commit a file (either adding new files or modifying existing ones). The svn command returns

svn: Commit failed (details follow):
svn: MKACTIVITY of ‘/fsaweb/!svn/act/7d64295c-af31-0410-91ac-f5f1c9feae78’: 200 OK (http://www.mydomain.xxx)

(the domain name has been hidden)

Further attempts to access the repository then hang. I’ve contacted the technical support who have successfully accessed and modified the repository from non dreamhost computers (I’ve seen the revision changes in the repository as proof). I tried doing the same from the computers at work as at home and both ended up with the same error. The only real link was both used the same ISP.

I have seen the other thread with a similar MKACTIVITY error but they are getting a 400 return code, I’m getting 200 which should indicate everything is working - but I’m not even getting challenged for the password.

I don’t have any special proxies setup that I’m aware of. I’m accessing the repository from behind a NAT, but my browser can show me the directory contents fine, it is just the svn client program running into problems. The HTTP logs indicate things should be working fine too (no errors listed).

Does anyone have any ideas of what the solution could be?


#2

I almost exclusively use SVN+SSH, which might be an option for you if you can’t find another solution to your problem. Let me know!

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#3

I found the http:// access failed for my ISP. It worked for some other ISPs. The svn+ssh access works, so I’m using that now.