Subversion: Checking out to local drive via CLI


#1

I’m much better with GUIs but rapidSVN won’t work through my employers proxy server so I’m stuck doing this with the command line. I have the first part of the checkout command down so it’s no problem getting it to check out what I want. I just can’t figure out how to get it to put the working copy in a directory on my c: drive. All of the examples I can find seem to have it checking out to the server. Thanks.


#2

I’m going to assume you’ve already got Subversion installed on your workstation (GUI front-ends don’t count). If not, you’ll want to do that first.

Once installed, fire up a command prompt, navigate to the directory you want your working copy to live in, and use the following command, where “directory_name” is the name of the directory you want on your system:

svn checkout http://your.svn.host/path/to/repos directory_name Doing this over SSH is recommended for security reasons, but if you’re using Windows you’re stuck with HTTP. Note that, unless it had a built-in SSH client, this is exactly what your Subversion client app was doing, so if that won’t work this probably won’t either.

You’re probably already aware, but the O’Reilly Subversion book is can be read in its entirety on-line.


If you want useful replies, ask smart questions.


#3

Thanks for getting back to me. I somehow overlooked the fact that I was going to have to put it on my local machine when I read the book. And the way the GUIs seemed to work just enforced my misunderstanding. Now it makes a lot more sense.


#4

Have you tried ?
http://tortoisesvn.tigris.org/download.html
It is a svn+ssh client for Windows, and have a little GUI…
Not sure if support proxy… but if you have the port 22 open it can work, also… It takes less than 10minutes to test.

Regards…


#5

I’ve used it at home but figured it would run into the same problems. I’ll give it a shot. thanks.


#6

Tried it and I’m having the same issue as with rapid. TortoiseSVN lets you make adjustments for proxy servers and I fiddled with that. The closest I’ve been able to come is having the .svn folder download. It then stops and says the files are locked and to run cleanup. I run cleanup but it doesn’t fix the problem. Maybe this just isn’t going to happen. It ashame, it’s one of the reasons i was interested in Subversion.


#7

Runned the cleanup on the server or on the client?.. chances are that you need to do the cleanup on the server… I have worked with svn for a long time and on the 1.x series, there are really anoying troubles having users do commit & use the files on the server (i.e. ssh to the server work there, call for svn co, or some of that like) and have clients accessing via svn+ssh remotely… the best solution I found time ago (had changed a lot) was to only had remote access to svn files or only had local access to the files, but fixing permissions first… let me search I have post about… on some I have posted on my blog.

Some things are on spanish as is my mother tongue… but the ones related to svn and the problem with berkeley locking are on english.

Regards


#8

If my repository is hosted with DH, won’t it have to be using a secure server and a unique IP for ssh to work?