Subdomains


#1

Is anyone still having trouble with the DNS resolve time. I changed nameservers about a day ago and one domain still points to the old server (when it shouldn’t since those nameservers have been changed 0.0), and most (all bu about 5 of 80) still point to the old servers subdomains, when of course they should not either.


#2

DNS propagation usually completes in 2 to 5 days.

-Scott


#3

I suspect the you simply need to wait it out. DNS propigation take take upwards of 3 days. You might want to double check with your registrar and make sure that the DNS changes you put through have ‘stuck’ - it still shows them pointing to dreamhost.

It’s also possible that your machine is caching the page and you need to force a refresh. If you want you’re welcome to post a few of the domains you’re having problems with and a few of us will see where they’re pointing to from our locations.

–Matttail
art.googlies.net - personal website


#4

2-5 days, huh? Well, I guess I am just going to have to stick it out and wait. I did think to check my registrar to make sure that the changes stuck, and the whois for each one shows the Dreamhost namservers, so they’ve been entered, they just need to work! :stuck_out_tongue:

Let’s see… some that are still active that I can see… I’ll try the different domains…

http://visual.morbid-romantic.net
http://gallery.yuki-eiri.com
http://direngrey.baptism-of-blood.net

For those morbid-romantic.net and yuki-eiri.com have both seemed to resolve the main domains, just not the subdomains. For baptism-of-blood.net, neither the domain nor the subdomains have seemed to click through. Still the whois that I checked at the dreamhost nameservers listed, not the old ones.


#5

Have you added the subdomains in at dreamhost? I’m asking because all three of the domains are resolving to dreamhost for me, but all three of the sub-domains return invalid host.

Each of the domains and sub-domains should be listed in the panel > Manage Domains area. Are they appearing there?

–Matttail
art.googlies.net - personal website


#6

Added to dreamhost? No. Does that make a difference? My stupidity. I had thought that it wouldn’t matter since I DID add blog.morbid-romantic.net, and it didn’t work at dreamhost, but kept forwarding to my old one, so much so that I couldn’t complete the install since it told me that my install was already complete.

But now, my subdomains (the ones added) seem to be working. I suppose that’s safe to assume the others will when I add them, too.

Thanks for your patience and ALL your help. I appreciate it.


#7

Yes, every subdomain that you want to use must be added through the panel. If it not, when you try and ping it, or visit it in your web browser there will be no DNS entry at DH for it, and you get the ‘can’t find hostname’ error.

When you visit a domain or subdomain, your browser says “I’d like the page for example.com”. The DNS directs you to the IP address for DH’s name servers. The Name server says, yeah ok I’ve got an entry for that, request the page from this IP address. If that subdomain doesn’t have an entry in the name server than it repiles saying “I don’t know any site by that name, sorry” :slight_smile: (sorry for my querky explination)

–Matttail
art.googlies.net - personal website


#8

I get it now. That makes a lot of sense. :stuck_out_tongue:

Now, if only http://www.morbid-romantic.net/aboutme.php?fanart and http://morbid-romantic.net/aboutme.php?fanart would show the same page, I would be happy. I am assuming the reason why one is different from the other (the old page before I updated it) has to do with the DNS? Because in the webpanel, I did say that I wanted both www.domain.com and domain.com to work.


#9

well, isn’t that interesting. AFAIK it shouldn’t be a DNS issue. “www.” is technically a sub-domain, so if the domain is resolving both should work exactly the same.

When I ping morbid-romantic.net and www.morbid-romantic.net I get a response from your DH server, yet I get two different pages in my browser… I reccomend putting in a support ticket and having them look at it. Hopefully the smart support people will know what’s wrong.

–Matttail
art.googlies.net - personal website


#10

Thanks, I just send in a support ticket. I’ve tried everything to figure out why I am getting two pages, and I know I’m not smart enough to figure it out.

Everything was working fine for a while, but now the rest of the pages and subdomains are once again forwarding to the old servers stuff, so I guess the DNS are just quirkly like that until they settle. Just as well, I need a break.


#11

It is treated as a subdomain, including an A record that’s the same as the A record as the domain itself. So your ping test makes sense.

However, I don’t understand how www. could send you elsewhere. Apache’s Virtual Host setup will generally use the domain name (and/or subdomains). “www.domain.com” should be in there with the “domain.com” entry.

So I just tried both out and they send me to the same place. However, you have some errors in the My Sites block, probably trying some PHP includes that are disabled in DreamHost’s PHP configuration.

-Scott


#12

I am going to fix the includes one by one since the Dreamhost way of doing things is different from my old host. Unfortunately for me, I’m not able to see any of my files as hosted by Dreamhost. Only one out of every ten clicks gets me to the actual Dreamhost pages-- 9/10, it takes me to the pages on the former server. I’m still even able to get into my old domain’s cpanel.

I just don’t get why one second a page will lead to the Dreamhost hosted page, and then the next second it will lead to the old page on the former server.

I’m waiting for Dreamhost to get back to me, but it’s been hours and the ticket has remained unanswered. I just don’t get it, truly


#13

That really sounds like DNS. It takes at least a couple of days for this to work itself out. In the mean time, you can try using the dreamhosters.com approach as covered in this Wiki article:
http://wiki.dreamhost.com/index.php/DNS_-_Viewing_site_before_DNS_change

I’d suggest you set up a yourdomain.dreamhosters.com as a mirror of your existing site.

-Scott


#14

I can’t make sense of it. Pages aren’t sticking, everything is all over the place, and some domains just don’t seem to be resolving at all. I suppose time is all I need.

I did set up one of those mirrors, but it never seemed to work. I just checked it and it still doesn’t work. Maybe I did it wrong, I don’t know.