Subdomains / Custom DNS


#1

Since I haven’t heard back on my support ticket yet, I’m trying my luck in the forums:

I am running into issues trying to set up various subdomains on one of my domains using the custom dns feature. I have added two CNAME records that point to “mydomain.com” and “www.mydomain.com” respectively, neither of which work. Each of these URLs results in a “bad_httpd_conf” error. A forum posting suggested to go into the domain’s “Edit” page and save the settings (even without any changes), in order to trigger rebuilding the apache config. I tried this and unfortunately this made no difference.

I was able to successfully setup a new subdomain using the “Add Domain” feature and configuring it to mirror “mydomain.com”, but I would prefer to be able to manage this using custom DNS.

Ultimately, I would like to be able to setup a wildcard alias in order to manage subdomains dynamically in a Rails app that I’m building for this domain. Does anybody know if this configuration is currently supported, and if so, would it be a simple matter of setting up a CNAME alias for “*”? The Wiki and knowledge base is a bit spotty on this and indicates that wildcard subdomains are disallowed or at least discouraged for shared hosting, but that statement appears to have been made before allowing things like custom DNS and other relaxations, so I’m not sure if this is still accurate.

Any help or pointers would be appreciated.

-sfgeek


#2

Has this been resolved yet? How long after setting up the subdomains were you seeing this error? After setting up both full domains, and subdomains, I saw the “bad_httpd_conf” error for maybe a couple hours I think. I got to the same place via the ip address listed in domain setup though.

Bypassing the dns server completely, indicates to me that it isn’t the source of the problem. After giving the new names a little time to propogate, I am having no problems now.


#3

I had set up the DNS entries Saturday morning, and as of now (Sunday evening) I am still having the same problems.

I am pretty certain that this is not a DNS issue, as all the subdomains I have set up resolve properly using nslookup, etc. So I’m wondering what else there is to propagate. Somehow it feels like an Apache issue…


#4

Yeah, that’s far longer than I have ever experienced that situation, even when I registered a new domain name through a different company that pointed back to DH. Guess it might require wading through that nasty waiting game of tech support. shiver

Sorry I can’t offer any solutions.


#5

No problem, thanks for taking an interest anyway. :slight_smile:


#6

You get the bad_httpd_conf error when you request a domain that is not configured in Apache.

You can’t just add a new entry to DNS because this doesn’t setup the required Apache configuration. You need to use Add Domain to set up Apache.

On each shared server there are multiple Apache servers, each on a different IP address. Each time you use Add Domain, it will pick and configure an Apache server and setup the DNS records to point at the correct IP.

I don’t think wildcard DNS/subdomains are supported at the moment.


#7

I finally understood this stupid DH problem…
of course the techsupport has been so useless on this issue I had to freakin’ figure it out myself. techsupport only tells you vague foo about DNS takings two days to refresh and they just regenerate the httpd.conf thinking it would solve everything magically. that’s what happen when you put kids on the support.

the thing is support did not even know how to check the important details that makes things fails/works. I know they don’t know, because know I know what was wrong with my setup, and if they knew just a little bit about their servers, that would have check that ages before.

I got the tip to solve the problem on this thread actually.
http://discussion.dreamhost.com/showthreaded.pl?Cat=&Board=forum_troubleshooting&Number=36842&page=&view=&sb=&o=&vc=1#Post36842
its all beautifully hidden in this sentence.

[quote]On each shared server there are multiple Apache servers,
each on a different IP address. Each time you use
Add Domain, it will pick and configure an Apache server
and setup the DNS records to point at the correct IP.

[/quote]

that’s it… there is multiple instance of mysql and apache running on a same server answering to different IPs. when you create your vhost. the system automatically assign your vhost to an apache instance and a mysql instance.

I’ll bet you most people having problem are those like me managing their DNS zones on their own. thing is. dreamhost is doing everything automatically on their DNS but of course not on ours. but support people don’t know how to check things apparently. anyway.

to fix this problem
-> in the panel
-> click domains
-> click manage domains
-> spot the line about your broken vhost
-> hit the DNS link
-> check the IP for www* and make sure your entry in your DNS fits.
-> same for mysql (can and most likely IS a different IP.)

it worked on the first shot for me.

I consider dreamhost owe me 6 months of service for this. I never been able to use my account because of this bug they never been able to fix.


#8

IIRC, for what you’re doing wouldn’t it have been better to but A records in, rather than CNAME? CNAMEs are for when you’re configuring a new site.