Stupid ionCube question again


#1

Hey all

Hope someone here can help me out - it’s another stupid ionCube related question here.

I’ve been at it for nearly 2 weeks to try and get ionCube installed. I’ve done exactly as it says in the wiki, even made sure i’m using the correct loader, double/treble checked the paths in the php.ini (which is in the cgi-bin) folder in my subdomain folder, and the statements I need in my .htaccess file.

As I couldn’t get it to work, I got in touch with the company I’ve bought a module off to see if they could install it and they have been trying for a week to install ionCube. They provide the installation as a free service to their customers and they’ve also have been unable to install ionCube on my Dreamhost account.

They’ve also attempted to see if ionCube actually installs on most of their customer’s Dreamhosts account and guess what - they’ve had no luck! - I know they’ve been trying to attempt the install as I’ve been monitoring their account usage and can see their activity.

I’ve been in touch with Dreamhost support and as we all know they do not provide support, I actually had an email from Daniel in DH Support to confirm he’s made a slight amendment to my .htaccess file and it’s now working but really it isn’t, and then after my follow up email I’ve been told ‘sorry we can’t do anything’.

I’m hitting a brick wall here and was wondering if anyone can help. I’m checking the phpinfo file too and it seems that the custom php.ini is not being recognised at all as the one which is installed by DH is the only one being picked up.

Any clues? I didn’t realise how hard it could be to install something which is really so simple.

Thanks in advance

Anis


#2

Ensure these fundamentals:

  1. That your ini is being used.

  2. That the ini at 1. contains the correct extension=path.

  3. That the correct loader is in the path reflected in 2.

Maximum Cash Discount on any plan with MAXCASH


#3

Hey sXi

Thanks for your reply (I’ve already seen your other post with help on ionCube which I followed and still couldn’t get it to work).

  1. My ini isn’t being used and I’m trying to figure out how I get ensure my ini is being recognised.

my phpinfo file is here:

http://ads.voiceofbolton.com/phpinfo.php

That’s one of the things I’ve been trying to figure out for a while. Even though my php.ini and the php-wrapper.cgi is located in the cgi-bin folder of the root of my domain folder (ads.voiceofbolton.com), the phpinfo shows it’s not using the correct ini file.

I’ve uploaded it and set the chmod to the correct permissions etc. but still no luck.

  1. the ini contains the correct zend extension path. I’ve double checked it again and again. I’m not using the .tricorn method to link to the ionCube folder, instead i’m using the /home/username… method.

  2. I’ve just re-installed the correct loaders and have done this a few times now. I’m using the x86_64 loaders as specified in my phpinfo.

Hope you can figure out where I’m going wrong.

Thanks

Anis


#4

Anis,

Just a word here. You, and your vendor, might want to take a look at the history of the wiki’s page on php.ini. There has been a lot of discussion as to the best way to approach this, and the most recent versions of the page have deviated considerably from the initial guide that was there.

I have always used the older scripts and methodology that preceded the latest revisions (I still do) and I have no problems with it. Your post makes it clear that you are not successfully loading your customized php.ini file, so I’d focus on getting that working first.

Once you have the customized php.ini file working, and loading, then installing the ioncube loader using it is rather trivial, but without that, or your own PHP installation, it will not work.

Wiki’s are, by definition, dynamic and reading the discussion page, and looking at some of the older versions where this was done “differently” may well be useful to you.

–rlparker
–DreamHost Tech Support


#5

hey rlparker

how do i get the custom php to be recognised? stupid question I know, but I’ve tried everything I know of. I’ve been in touch with DH Support, and Daniel has tried to help me but as you’re aware they can only provide limited or no support at all.

I’ve done everything not only the wiki but google has to offer on this subject but I just can’t get my php.ini to be recognised even though it’s in the cgi-bin folder for that domain.


#6

2 & 3 are irrelevant until you fix the problem at 1.

Offhand, I’d reckon you’re using an invalid wrapper.

Worst case scenario is it’s a server directive (only ever seen this once on a VPS).

Maximum Cash Discount on any plan with MAXCASH


#7

That is all the function of the .htaccess handler information. No matter what else you do, if that is not done properly, it will not be recognized.

If you read through the history of that article, you will see a major change in the article’s description of how all of this is done (not just the .htaccess file and getting your custom php.ini recognized and used, but the whole approach to the problem) that occurred on August of 2008. The versions of the page before that used an entirely different approach, and quite frankly people had less trouble using that version for almost 2 years than has been reported using the newer version for the last 2 months. Hmmmm.

Take a look at:

http://wiki.dreamhost.com/index.php?title=PHP.ini&oldid=20944. It just might work better for you.

–rlparker
–DreamHost Tech Support


#8

Cheers rlparker

I’ll have a read of that page.

sXi is currently on the case and he’s offered to take a look at my setup. I’ll let you all know how I and sXi get on.

Thanks

Anis


#9

Just did a little experiment here. I didn’t even use any of the scripts on the wiki to install my custom php.ini and get PHP to use it. It took less than 5 minutes, and went like this:

  1. Create a cgi-bin directory in the domain’s web space
  2. copy the default DreamHost php5.cgi and php.ini file into it
  3. create an .htaccess file containing two lines

Done!

Tested with phpinfo() and confirmed that the PHP-CGI from the cgi-bin directory was being used, and that the php.ini was loaded from that directory.

… sometimes it’s just easier to do it by hand. :wink:

–rlparker
–DreamHost Tech Support


#10

Hey guys

I think i’m a step closer - just managed to get my php.ini recognised by phpinfo.

sXi / rlparker - thanks for all your help.

I hadn’t added the following line to my .htaccess:

AddHandler php-cgi .php

However, for some reason each time i added this it kept crashing my site - this time it’s worked!


#11

Outstanding! *nix files like to be worked on with *nix editors; often using other stuff and uploading can introduce bad characters/line endings which can break things! Just a thought … :wink:

It most certainly will not work without that AddHandler directive.

–rlparker
–DreamHost Tech Support