Stopping SSL Certificate "Errors" in Mail.app


#1

I use Mail.app for my e-mail and have it configured to access my Dreamhost account with IMAP. I use SSL because I often use my laptop at school/work/elsewhere.

The problem is that when I first open mail (first connect to the IMAP server) and when I first send an e-mail in a session (first connect to SMTP server) Mail.app pops up a box complaining that the SSL certificate for my domain is invalid and I may be getting scammed. Both certificates read “Dreamhost” and not my domain, obviously.

Is there anything I can do to suppress these errors?

– Michael Cook


#2

It’s in the wiki:
http://wiki.dreamhost.com/index.php/Mac_OS_X_Mail

-Scott


#3

I looked through the FAQ but I missed that.

Bit of a hack, but it works. Thanks.

– Michael Cook


#4

OK, it’s still happening. My guess is that now it’s mad because the certificate is self-signed.

– Michael Cook


#5

I wonder if going into Keychain Access and setting it to Always Trust would help.

-Scott


#6

I never would have thought of looking in keychain.

But I checked and I don’t even see the certificate in there, so I can’t set that.

– Michael Cook


#7

That wiki article has a section on how to download a copy of the SSL cert and add it to your keychain. It’s in the 10.3 and below part.

-Scott


#8

That did it, thanks!

– Michael Cook