Still can't access RSS url

software development

#1

in http://issmedianews.com I’ve tried several ways to get the rss newsfeed to work. The original used ajax, so I got another that doesn’t use ajax Here is the non-ajax page: http://issmedianews.com/demo.htm. It gives an error message that tells you it can’t access the feed.

The thing is, both RSS scripts work on 3 other sites, but not Dreamhost.

The original ones that I have in the sidebars of the site don’t give an error, but they also can’t access the feed.

Here’s the url outside of the wordpress page (same results)
http://issmedianews.com/worldnews.html

Here’s the code for worldnews.html:

ISS News Feed /* CSS only needed for the demo */ body{ font-family: Helvetica, Lucida Sans Unicode, Arial, sans-serif; /* Font to use */ background-color:#ffffff; width:100%; margin:0px; } #mainContainer{ width:135px; margin:2 auto; text-align:left; background-color:#FFF; padding:0px;

}
.clear{
clear:both;
}

/* End CSS only needed for the demo */

#rssBox{ /* The main box for the rss scroller /
width:135px;
margin:2px;
float:left;
height:245px;
border:0px solid #317082;
padding:2px;
font-size:0.8em;
background-color:#ffffff;
/
Never change these two values */
overflow:hidden;
position:relative;
color: #44496F;
text-align: left;
}

#rssBox .slide{ /* A specific slide /
background-color:#ffffff; /
Light blue background color */

}

.rssBoxDate{
display:inline; /* I don’t want to show the date /
font-size: 10px;
}
.rssBoxHeading{ /
Heading of RSS item /
font-weight:bold;
color:#44496F;
margin:1x;
}
.rssBoxDescription{ /
Description of RSS item */

}
.rssBoxLink{ /* Read more link /
color:#006666;
text-decoration:none;
}
.rssBoxLink:hover{ /
Read more link - mouse over */
text-decoration:underline;
}

loading world headlines ... Please wait

The non-ajax code is much more complicated and has a couple of include files, so I’m not including it here.


#2

As for as the JavaScript AJAX version is concerned the problem is with the PHP script and not the JavaScript.

You also appear to have a problem with your blog software - it is causing pages to come up blank in Firefox or Internet Explorer 7. I bet you have the WordPress option “WordPress should compress articles (gzip) if browsers ask for them” under Options -> Reading turned on.

:cool: openvein.org -//- One-time [color=#6600CC]$50.00 discount[/color] on [color=#0000CC]DreamHost[/color] plans: Use ATROPOS7


#3

Thanks for the tips–I bet I do have that turned on, and I’ll check on the blank pages problem. To me it looks like they’re coming up each time, but maybe it’s from the cache…I suspect I need to change templates.

What has me puzzled is that the rss feeds don’t show up when you call them up as separate pages, outside of the blog, either. I tried that different dhtml version, thinking it might just be an incompatibility somewhere, or a bad RSS link, but get the same results. The unmodified demo version works fine on the old site, but can’t reach the RSS feed on Dreamhost.
Old site: http://76.162.222.65/demo.htm
Dreamhost: http://issmedianews.com/demo.htm
I don’t know know if that will give a clue, but it might. I’m totally stumped.