SSL Setting problem (domain shows both SSL and Non-SSL)


#1

Hi Dreamhost,

I’ve set up SSL, but the problem is that my domain shows SSL and Non-SSL.

Would you please let me know how to make them on the same page?
It should show SSL since I’ve set up…

Thank you for your help.
Skye


#2

1.) In addition to what you’ve already done, you’ll also need to set up a redirect from HTTP to HTTPS.

On a shared server using an Htaccess file, add this above any other rewrites:

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

2.) You’ll also need to change any in-site links using absolute paths to HTTPS.

Note: code updated to allow wrap for smaller viewport.


#3

Hi keyplyr,

Thank you for help, it works now :+1:
Have a nice weekend :blush:

Thanks,
Skye


#7

When it comes time to add your custom SSL certificate to either your origin server or CDN, you need to ensure that the proper certificate information is provided. This includes all intermediate certificates as well as the private key. Double-check that there are no empty lines that may be causing any issues.
https://www.keycdn.com/support/ssl-error

If you need to generate intermediate certificates, check out our chain composer tool as well as our certificate checker.
To fix an outdated SSL certificate, this can simply be done by renewing your custom SSL certificate with your dedicated certificate authority or if using Let’s Encrypt, you can simply run a renewal command.


#8

If using cloudflare, you need to check the Always https option. Also, simple SSL plugin like I’m using on watchseries.tube will do the job as this might me due to mixed content. You can also try permanent https redirect through .htaccess file.


#13