SSI not working


#1

Hello,

I’m having trouble getting Server Side Includes to work.

I keep getting the error following error which isn’t to helpful:
[an error occurred while processing this directive]

I’ve tried a variety of SSI based on examples in the Knowledge Base.

IE: (with out the \s)
<!–#virtual include="/potm/potm.pl" -->
<!–#include virtual="/potm/potm.pl" -->
<!–#include file="/potm/a.pl" -->

Any suggestions?


#2

That’s the correct markup to use (minus the slashes).
Using virtual includes for SSI means the target is going to be processed by Apache. So if your target is a script or other program, its output must start with an HTTP header section.
Also, you should be able to browse to the SSI script - have you tried browsing to http://yourdomain/potm/potm.pl If you get an error then the problem is with the script, not your markup. Maybe you need to chmod it to 755. One thing to keep in mind is that a script called through SSI will have a different environment than when requested by a browser and that may generate a different set of errors from the script.