SSI issues after Apache upgrade


#1

I just started having problems with my server side includes (SSI) after the Apache (simple point) updgrade. My pages include PHP scripts which can accept parameters from the URL. All of a sudden they just started ignoring anything in the URL. If the parameter is hard coded into the line of SSI code on the pages it works fine, just not from the URL.

Is anybody else having this problem? Is there something I can add to an .htaccess file to make it start working again?


#2

OK, so I figured out how to make my pages work again.

I added $QUERY_STRING to my SSI, i.e.

< ! - - #include virtual="/scriptname.php?parameter1=a & parameter2=b & $QUERY_STRING" - - >

(forgive the weird spacing, for some reasone the PRE tags in this forum aren’t working)

So now a new parameter in the URL gets filled and replaces $QUERY_STRING. I recognized this from including PHP scripts withing PHP pages, but I never had to do this before when including PHP scripts in parsed HTML pages–not until this Apache upagrade. I hope I don’t have to edit all of my pages on all of my sites now…