SSI (includes) will not update


#1

I am using SSI include to insert a global menu in multiple pages of a website. The menu updates fine on one DH site. I was able to install the menu to all pages (with .shtml extension) of a second site but it will not update automatically when the include file is updated.
Here is the code inserted in each .shtml file:

The menu I am using has the following .css and .js files:

Any help greatly appreciated by this ssi novice.


#2

If the SSI include comment is replaced by content (other than an error message) then the SSI is working and you are dealing with a browser cache issue. You can diagnose without a cache using a web service like http://web-sniffer.net/ or from the shell using wget/curl to fetch the page and examine the HTML.


#3

Thanks for such a quick reply. It does not appear to be a cache issue because another website using the same ssi method does update successfully on my browsers. I am wondering if there is some setting on the server side (Dreamhost) that is making it work for one site but not the other. The two sites are
http://sjsacenter.org (menu updates as needed)
and
http://stvincentftmyers.org (menu will not update).


#4

Then that means it is one of two things:

  1. Your HTML file does not use the SSI comment. If you browse to the page, then “Save As” to your local computer, the saved HTML file will not have the SSI comment; it will have the contents of the menu file instead. If you uploaded this version of the page to your web site, no wonder the menu doesn’t update - there is no SSI directive.

  2. The SSI comment refers to the wrong file. But it refers to a file that exists. Easy enough to test, since the path used is also a working URL, just browse to http://stvincentftmyers.org/includes/menu.txt and make sure it is the same file you are updating.


#5

BINGO! The problem was #1. Everything is working correctly now that I have entered the include code
into each .shtml file and saved it in “Notebook” before uploading to the server. Of course I also had to remove the menu content from the file to avoid getting duplicate menus. Thank you for sharing your expertise. :slight_smile:
Ed Dilgen