Ssh unzip error

wordpress

#1

I’ve followed the directions to unzip a file (a preconfigured WordPress Installation named ‘blog.zip’) using SSH unzip:
http://wiki.dreamhost.com/SSH#Decompress_ZIP_Archives_-Upload_a_gazillion_files_at_once-_Mini_Windows.2FSSH.2FPutty_tutorial
But am getting errors:
checkdir error: cannot create blog
unable to process blog/xmlrpc.php.
etc.
(Seems to be an error for every item in the zip)
I’m sure I’m in the right subdirectory because I when I type:
dir
I can see the correct files.
Why won’t it unzip?!
(And while I’m at it, why is the unzip function in net2ftp limited to 2MB The concept is to create my own 1-click installs.)
Thanks!


#2

What is the file permission on the file?

Save $97 (MAX Discount) with code: [color=#CC0000]97YES[/color] Sign Up NOW or More Codes Here


#3

777

Thanks for asking.


#4

What is the permission on the folder? You need to have write permission on the folder at least.

I don’t know whether it is related to your case or not. But when I did search on the web, it says it could be due to the low version of unzip. Solution is to try to use Full Path when you unzip.

Save $97 (MAX Discount) with code: [color=#CC0000]97YES[/color] Sign Up NOW or More Codes Here


#5

I changed the permission to 777 on the folder and it didn’t make any difference.
I’m logging into a shell acct, then navigating through the various directories to get to the directory (website) the .zip is in, and then trying to unzip file.zip
I’m working from a Mac using Terminal.


#6

Is there a folder blog existing in the same folder when you tried to unzip the file?

If so, have you tried unzip -f blog.zip or unzip -o blog.zip?

I am not a mac user. Hope we can get the luck to solve the problem.

Save $97 (MAX Discount) with code: [color=#CC0000]97YES[/color] Sign Up NOW or More Codes Here


#7

You know, I don’t think that could be it, because previously I’ve done it with a smaller blog.zip file using net2ftp with no issues. In the meantime DH Support has come to my rescue and unzipped the file, suggesting the possibility of permission errors (although I tried 777ing both the file and the directory). I’ll do some more experimenting later today, including your suggestions, and get back to the thread if I find anything.
Thanks for your help.


#8

:frowning: Till now, I still have no idea what’s going wrong.
:slight_smile: But I am glad that DH support solved your problem.

Save $97 (MAX Discount) with code: [color=#CC0000]97YES[/color] Sign Up NOW or More Codes Here


#9

Roberto, the DH person who handled my support request figured it out. Rather than turn my regular (humphre@mywebsite.com) account into a Shell account, I had made another one (humphreyshell@mywebsite.com). I could navigate to the proper directory and see the file to unzip but got all the errors when I tried. After I gave my regular account (humphre@mywebsite.com) Shell status I was able to SSH unzip the files no problem. This is great.
Thanks for your help.
Ciao for now.