SSH Public Key authentication?


#1

For a variety of reasons, I’d prefer to use public-key authentication over the usual password challenge when I ssh into my dreamhost account. I’ve done this before with other hosts, and use ssh2/public key auth all the time. For some reason, it doesn’t work on my shell accounts on dreamhost; I’ve tried putting my “authorized keys” in all the usual places (.ssh/, .ssh2) but it still asks for a password on every connect.

Has anyone else gotten this to work?


#2

Answered my own question. Perms on the .ssh directory have to be 700 for auth to use the file.


#3

I use SSH2 to login without a password.

I’m guessing that your keys don’t have a passphrase, or that this isn’t the problem.

Is your .ssh directory on Dreamhost set to 700? Is your authorized_keys file set to 600?

Have you done ‘ssh -v user@host’ to see what’s going on as you log in?

-Scott


#4

It was permissions on the .ssh directory. Setting them to 700 fixed it. Realized it as soon as I had posted.


#5

i have the same problem.

I have created ssh folder on home directory with 700 permission…in my domain folder i have modified the authorized_keys file with my public key and move to the ssh folder…but when i try to login it ask me the password…why ?


#6

i have solved…i created ssh folder without the “.” before the name.

Now workk


#7

None of these work for me. On my main account I can log in just fine with public key. On my secondary account (with 700 on .ssh and 600 or 400 on authorized_keys) I can not. What gives?


#8

Try ‘ssh -v’ to look for clues as to why it doesn’t work.

-Scott