SSH Problems


#1

Hello

I’m trying to SSH to my server using Putty. I’m entering www.domainname.com as the host, SSH as the option along the top, and connecting. I then enter my username and password, and I see a flash of some ascii art spelling out the name of my server, then suddenly the window closes, so I can’t read what the message says. I tried setting the window to close ‘never’ but it still does. It is a new Putty install, and I have not touched any of the options. I have tried the Putty install at work, which I use every day to SSH to our server at work without any problems, and exactly the same things happen.

Any ideas what I could be doing wrong?


#2

Chris,

That’s a “classic” response to trying to log into the shell when you are not a “shell” user. Unless you have “shell access enabled”, you won’t be able to get in.

What you are seeing happen is that your ftp only user is connecting, and going through the authentication process, then being immediately “dumped” because that user is not authorized shell access.

You can determine whether or not a given user is authorized shell access by visiting the link above. Get that sorted, and wait for it to “take”, usually in about 20 minutes or so (though it could be longer), and try again…you should be fine.

–rlparker


#3

Thanks for that

I was just coming back as I had found this out - I’m afraid I have a bad habit of managing to find answers to my problems just after I post about them… sorry about that!

Cheers,

Chris


#4

he he…no problem. Maybe someone else can benefit from the question/answer. :wink:

–rlparker