Ssh login - how to use my .bashrc by default


#1

When I log in to ssh, I am greeted with the [minsk]$ prompt like normal. I have updated my .bashrc file with some aliases and preferred display type (user@minsk:~/…$), but I must source .bashrc before it will load my settings. How can I have my settings loaded by default on login?


#2

Wrong file. It’s .bash_profile you want to update (remember: login = user = profile) .bashrc is for non-login shells.

Customer since 2000 :cool: openvein.org | Please don’t feed the trolls. :@


#3

Just add source .bashrc into .bash_profile

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost