Ssh keys


#1

I’ve been using PuTTY to have a ssh session with my server, and everything works fine … but my fingers are tired of typing my password.
Is it possible to SSH/SCP without a password on a shared DH server?
I tried a few ways … none of which are working with PuTTY.


#2

Absolutely! :slight_smile:

The DremHost Wiki article on SSH has this covered nicely, and it works fine with PuTTY.

–rlparker


#3

I read that but got confused somehow.
I think because the .ssh dir did not exist already … will try again.
Thanks for the quick help/reply.
So far I am very glad I switched from HostGator to DreamHost … just for the RoR on fastcgi alone.


#4

Yes it is.

Basically, you:

  1. Generate a public/private key pair with puttygen.
  2. Put the private key on your local machine.
  3. Put the public key in ~/.ssh/authorized_keys2 if you generated a DSA key or authorized_keys if you’ve generated an RSA key.
  4. Configure putty, remembering to add an auto-login username, the private key location, and to save the session info. I seem to recall that at one time, you needed to save the session as the hostname if you want tortoiseSVN to work properly.

The detailed instructions are on the wiki.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#5

Oops. Sorry for the dupe. I got involved in thinking about whether to recommend an RSA key or a DSA key. :slight_smile:

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#6

It still asks me for my password (at least I don’t have to type the username anymore).
I had to mkdir .ssh
Also, I should use probe.dreamhost.com and not my domain name, right?

I’ve tried both DSA and RSA … neither works for me.

I see the following in putty’s log:
Event Log: Reading private key file "C:*****\key.ppk"
Event Log: Pageant is running. Requesting keys.
Event Log: Pageant has 1 SSH-2 keys
Event Log: Pageant key #0 matches configured key file
Event Log: Trying Pageant key #0
Event Log: Server refused public key


#7

thanks all … i took a break, came back, and it works now.
bizarre, but i’ll take it
peace and prosperity to all


#8

Wow…

Never know that practice. Thanks Lensman as I also benefited from your reply. :slight_smile:

T-T-L
$97 off using [color=#CC0000]LuckyYou[/color] promo code (Just $22.40/1st year with Crazy Domain Insane plan) :cool: . Sign Up NOW