SSH Hangs on Login


#1

When I try to login to my ssh instance, I put in my password and then it just hangs indefinitely. If I look at verbose output, it accepts my password , and then the last message is:

debug1: Entering interactive session

And then nothing happens. If I hit Ctrl-C, nothing happens, the only way to get the terminal back is to kill -SIGKILL the process. I also have a computer running OSX, and I can connect just fine. I am using ArchLinux locally.

Any Ideas?

Thanks in advance


#2

When you say that you can ‘connect’ just fine, you mean via FTP and/or HTTP, right? Is SSH login activated for that user? (though it shouldn;t matter…)


#3

Thanks for responding, and sorry for taking so long to get back (you know, christmas season). Sorry, everything I mentioned is in reference to SSH. I had not tried FTP or HTTP. I did some poking around and I realized that if I plugged my machine into the router everything worked fine. Before that I had been USB tethering (android). I’m not sure exactly what it’s doing, but it appears that tethering with my phone presents some obstacle.


#4

Wow, that’s a pretty unusual way for that to break. I’d almost wonder if there’s some specific issue with the tethering app you’re using (or with the mobile carrier?) that’s causing this behavior.


#5

Can you ssh into other places while tethered? I’m wondering if that port is blocked.


#6

try telnet YOURDOMAIN 22 to see whether the port is blocked.