Ssh connection keep shutting down only in my user


#1

I’m using PuTTY to get ssh connection to a CentOS 6.9 machine but after I get a successful login, PuTTY shut down without error message. I tried in other user and I got access. I tried too with other Open Source software in my user and I couldn’t join the CentOS machine. Any help? Thank you so much!


#2

Where is this CentOS machine hosted? Who setup and maintains this machine? Do you have access to the SSH server log files?

What exactly do you mean by ‘PuTTY shuts down’? What other software have you tried exactly? what do you see on the screen? where are you connecting from?

these are only the first questions that pop to mind. Keep on debugging and let us know what you find out.


#3

Also please provide details about what distribution of PuTTY that you downloaded. Is it the official original Putty from: https://www.chiark.greenend.org.uk/~sgtatham/putty/ or some other distribution?


#4

This CentOS machine is hosted in our localhost (our companny maintains this machine). I do have access to the SSH server but with other user in my computer.
PuTTY shuts down without error message, I enter the user (root), password and after click Enter PuTTY closes. I tried with MobaXterm. I’m connecting from a Windows 10 machine using PuTTY 0.70


#5

Do you mean that the software on your Windows machine closes, with no error? If that’s the case, this could be a bug in the software you’re using. Can’t help you there, sorry.


#6

I selected the option “Never” in “Close window on exit” on PuTTY and the message that I get is this one: http://imgur.com/a/FdHac


#7

Looks like you cannot connect as root to the remote host and you have a proper error message. Look on google, the first result is

https://www.centos.org/forums/viewtopic.php?t=48714

You may want to ask your system administrators what’s going on so they can debug the issue on the server. Or just connect as an unprivileged user and su in the machine.