SSH Access


#1

Hi,

I am trying to enable SSH access to my DreamHost account. I did enable the Shell account for the account I am trying to access.

I am on a Mac, and I have tried (unsuccessfully) to access the account using: Macfusion, Cyberduck, and Finder. However, I can access the account using regular FTP, but just not SFTP.

I believe I am using the correct information, as far as the username, password, server (taffy.dreamhost.com), etc.

Has anyone had any luck using SSH access for their DreamHost account on a Mac? Thanks.


#2

Dunno if this helps, but it comes from the DreamHost Wiki (slightly paraphrased):

“Mac OS X users can find Terminal at /Applications/Utilities/Terminal.app. Once in a terminal session, type ssh username@your.domain.com to initiate SSH.”


si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#3

Do you get any error messages or does it just hang?

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#4

I use SSH (via Terminal) and SFTP (via Transmit) on my Mac all the time. All my users are Shell users and I’ve never had a problem. The programs you listed are for File Transfers. Perhaps it’s a Pref setting in your program. Finder definitely won’t do it, though.

-Scott


#5

Also, are you in a normal home setup or is this from a corporate LAN behind a firewall?

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#6

Thanks for all the help/suggestions.

Okay, I am using a normal home setup.

When I try the Terminal suggestion I get: Connection refused
When I try Cyberduck I get: Connection failed
When I try Transmit I get: Connection refused
When I try Macfusion I get: Remote host has disconnected

These are all attempts to connect through SFTP. I can, however, connect through FTP just fine using these same tools.

From the error messages above, it looks like my connection is being refused for some reason. Would this have anything to do with the fact that I have an underscore in my username? I thought that character was allowed.

Any ideas?


#7

Have you tried doing a simple SSH terminal connection? You can (obviously) use Terminal for this.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#8

@Lensman

Sorry, but how would I test a simple terminal connection? Is it the same as mentioned above? If so, I tried that. Thanks.


#9

And what did it respond? Oh wait, I see. It wasn’t clear to me that you had tried that as a debugging step because it was mixed in with the list of other sftp clients you listed.

At any rate, telnet to your server on port 22 and tell me what it says. It should give you some diagnostic string.

telnet yourdomain.tld 22should respond something like:

SSH-2.0-OpenSSH_3.8.1p1 Debian-8.sarge.6I suppose even in a home situation, there could be some firewall blocking port 22.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#10

Nope, it did not work.

When I type: “telnet taffy.dreamhost.com 22”

I get:
“Trying 64.111.122.9…
telnet: connect to address 64.111.122.9: Connection refused
telnet: Unable to connect to remote host”

I wonder if SSH is somehow screwed up on my computer, do you think?


#11

Reaching back in my hazy memory, I had to contact Support to get my home IP address unblocked for SSH access due to multiple login failures. Or it may have been somewhere else.

Anyhow, it’s possible they blocked your IP address for SSH connections. Drop Support a line with your home’s IP address, which you can get by visiting http://checkip.dyndns.org

-Scott


#12

jernomer,

Along this line of investigation, let’s try another ssh host to see if you can ssh anywhere else:
sdf.lonestar.org


#13

@sdayman

Thanks. I will give that a try. I assume you mean DreamHost support.

UPDATE: I just sent DreamHost support an e-mail. Hopefully, they will recognize the issue.


#14

@Lensman

I think that worked okay. Here is what I got:

“Trying 192.94.73.1…
Connected to sdf.lonestar.org.
Escape character is ‘^]’.
SSH-1.99-OpenSSH_4.4”

So it must not be on my end, right?


#15

Yep, make sure to let DreamHost support know the test you just did so they know that you can connect to port 22 on other servers. It looks likely that you’re having the same problem that sdayman is having.

BTW, I get a good result when connecting to taffy.dreamhost.com so you’re typing the server in right and the server itself seems to be ok.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#16

Okay, I sure feel stupid now. My firewall software was blocking all connections to the server. I have fixed it and now I can connect to the server just fine.

Sorry for wasting everyone’s time, and thanks for the all the help.


#17

Heh, I’m glad you figured it out. I’m hope that all the testing we did let you to figure out what it was the firewall. :slight_smile:

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#18

Yep, it was your comment that you could connect to the taffy server that made me think my connection was being blocked somehow. Thanks!